Bug 868093 - Several untranslated strings in Subsriptions section
Several untranslated strings in Subsriptions section
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Localization and Internationalization (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 00:34 EDT by Hedda Peters
Modified: 2013-12-16 09:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 09:23:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-10-19 00:34:14 EDT
Test run for i18n-L10n System Engine Test Plan for CloudForms v1.1 on build Beta 5 Snapshot

L10N: Content Management - Subscriptions

Description of problem:

* When uploading a manifest file, the error message was untranslated ("Subscription manifest upload for provider 'Red Hat' failed. Reason: Import is older than existing data ...")

* Messages in upload history and import history are untranslated e.g. "Starbucks file imported successfully"


Expected results:
All strings should be translated
Comment 1 Eunju, Kim 2012-10-19 01:38:42 EDT
Same issue confirmed for Korean(ko_KR).
Comment 3 Ivan Necas 2012-11-01 10:45:55 EDT
This messages comes from Candlepin
Comment 4 Hedda Peters 2012-11-01 19:25:43 EDT
I checked our Candlepin translation files on https://translate.zanata.org/zanata/project/view/candlepin.

All strings from my original report are translated either in Candlepin or CFSE project on Zanata, yet displayed in English in the UI:

"Subscription manifest upload for provider '%s' failed." -- CFSE
"Reason: %s" -- CFSE
"Import is older than existing data" -- Candlepin
"%s file imported successfully"  -- Candlepin


Having said that, there are still 6 untranslated strings (not related to this particular bug) in the Candlepin project from a recent update that we will try to have translated asap.
Comment 5 Bryan Kearney 2013-12-16 09:23:38 EST
Closing all i18n bus due to ne architecture. The goal is still a localized UI and CLI, but we will do this via a new round of testing.

Note You need to log in before you can comment on or make changes to this bug.