Bug 8681 - Core dump on call to strcat()
Core dump on call to strcat()
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-20 17:08 EST by Daniel L. Rall
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-01 15:33:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel L. Rall 2000-01-20 17:08:37 EST
I'm running the version of Kudzu that ships with RH6.1.

GDB told me that the core dump occurs during a call to strcat() when trying
to configure my SMC 1211 TX (rev 16) ethernet card (not during boot).  The
card relies on the rtl8138 module, which could not be compiled because the
2.2.13 kernel I was running at the time wasn't compiled to support the
driver's NEW or EXPERIMENTAL status.
Comment 1 Bill Nottingham 2000-01-20 17:19:59 EST
Can you get a full backtrace of a debugging version?
Comment 2 Bill Nottingham 2000-02-01 15:33:59 EST
This segfault was due to the parallel port issue with the kudzu
that shipped with 6.1 - fixed in the current kudzu.

Note You need to log in before you can comment on or make changes to this bug.