Bug 868185 - Error running katello-configure due to liquibase error [NEEDINFO]
Error running katello-configure due to liquibase error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
Tazim Kolhar
: Triaged
Depends On: candlepin-ibm
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 04:36 EDT by richard
Modified: 2016-04-25 20:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 868168
Environment:
Last Closed: 2014-07-02 10:07:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lzap: needinfo? (richard)


Attachments (Terms of Use)
katello-debug output (44.89 KB, application/x-gzip)
2012-10-19 04:36 EDT, richard
no flags Details

  None (edit)
Description richard 2012-10-19 04:36:45 EDT
Created attachment 629863 [details]
katello-debug output

Description of problem:

Error Running katello-configure on a rhel6.3 platform

Version-Release number of selected component (if applicable):
1.1

How reproducible:
Every time

Steps to Reproduce:
1. clean install of rhel 6.3
2. yum -y install katello-all
3. run katello-configure
  
Actual results:
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20121019-092845/main.log]
Creating Katello database user
############################################################ ... OK
Creating Katello database
############################################################ ... OK
Creating Candlepin database user
############################################################ ... OK
Candlepin setup

  Failed, please check [/var/log/katello/katello-configure/cpsetup.log]


Error Captured: debug: Exec[cpsetup](provider=posix): Executing '/usr/share/candlepin/cpsetup -k a4f680e240ddd33a439c9264 -u candlepin -d candlepin >> /var/log/katello/katello-configure/cpsetup.log 2>&1'
debug: Executing '/usr/share/candlepin/cpsetup -k a4f680e240ddd33a439c9264 -u candlepin -d candlepin >> /var/log/katello/katello-configure/cpsetup.log 2>&1'
err: /Stage[main]/Candlepin::Config/Exec[cpsetup]/returns: change from notrun to 0 failed: /usr/share/candlepin/cpsetup -k a4f680e240ddd33a439c9264 -u candlepin -d candlepin >> /var/log/katello/katello-configure/cpsetup.log 2>&1 returned 1 instead of one of [0] at /usr/share/katello/install/puppet/modules/candlepin/manifests/config.pp:43


Expected results:
Clean Install

Additional info:
Comment 1 Miroslav Suchý 2012-10-19 05:39:41 EDT
Can you please provide output of:
rpm -q liquibase
Comment 2 Ivan Necas 2012-10-19 05:48:02 EDT
@msuchy - this was already resolved over IRC. The causing issue was already filed against Candlepin https://bugzilla.redhat.com/show_bug.cgi?id=854732. I suggest keep this bug open as a tracker for Katello.
Comment 3 Lukas Zapletal 2012-11-05 06:10:47 EST
This was fixed upstream, I have added a katello-configure check of java --version command. It must show OpenJDK string. Other JVMs are not supported because Candlepin will fail.

Can you please show us output of this command

java --version

BEFORE you run katello-configure in the SAME shell?

Nightly build should prevent from starting katello-configure when incorrect java JVM is on the PATH.

(I was unable to reproduce on my testing boxes, it looks like different Anaconda profile or something like that. Thanks for help.)
Comment 4 Bryan Kearney 2014-01-21 14:07:34 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 8 Tazim Kolhar 2014-05-19 03:41:59 EDT
VERIFIED
Comment 9 Bryan Kearney 2014-07-02 10:07:13 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.