Bug 868228 - [RFE] Add TUI testcases for several network configurations
[RFE] Add TUI testcases for several network configurations
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 06:16 EDT by Fabian Deutsch
Modified: 2013-11-19 03:09 EST (History)
11 users (show)

See Also:
Fixed In Version: 2.7.0
Doc Type: Enhancement
Doc Text:
Feature: Add TUI testcases for several network configurations Reason: Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 03:09:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-10-19 06:16:36 EDT
Description of problem:
Currently the network configuration is done through the TUI. Because network configuration is an essential feature these parts could be covered by TUI igor testcases to find regressions early.

A testcase would set the configuration through the TUI and check if the resulting configuration files match the TUI configuration.

Suggested testcases:
- Basic DHCP
- Basic DHCP with VLAN
- Basic static
- Basic static with VLAN
- Basic disabled
Comment 1 Sandro Bonazzola 2013-11-19 03:09:08 EST
> Fixed In Version: 2.7.0

Moving this to closed.

Note You need to log in before you can comment on or make changes to this bug.