Bug 868240 - [WHQL][balloon]two warnings when running DevFund INF Test job for win8/win2012
[WHQL][balloon]two warnings when running DevFund INF Test job for win8/win2012
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Gal Hammer
Virtualization Bugs
: ZStream
Depends On:
Blocks: 1091323
  Show dependency treegraph
 
Reported: 2012-10-19 06:28 EDT by Mike Cao
Modified: 2014-06-13 05:24 EDT (History)
10 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-77
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:24:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2012-10-19 06:28:05 EDT
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-prewhql-41

How reproducible:
100%

Steps to Reproduce:
1.Start VM with balloon
2.running dev fund inf job
  
Actual results:
two warnning about balloon driver 
1.Driver package C:\Windows\Inf\oem1.inf specifies LoadOrderGroup for registration of service BALLOON display name "VirtIO Balloon Service". This is not recommended.
2.Driver package C:\Windows\Inf\oem1.inf does not use PnpLockdown directive in its version section. It is recommended to specify PnpLockdown = 1 in the version section.


Expected results:
no warnings

Additional info:
not a testblocker
Comment 2 Gal Hammer 2013-03-14 11:12:28 EDT
Mike,

Is this test run on the other drivers too? Because I see that the virtio-serial's inf file include the LoadOrderGroup directive and doesn't have PnpLockdown as well.

Thanks.
Comment 3 Mike Cao 2013-03-15 02:38:37 EDT
(In reply to comment #2)
> Mike,
> 
> Is this test run on the other drivers too? Because I see that the
> virtio-serial's inf file include the LoadOrderGroup directive and doesn't
> have PnpLockdown as well.
> 
> Thanks.

Yes .

I Tried w/ serial on build 51 .hit the exactly same issue .
But this bug is not urgent as HCk accepts warnings
Comment 8 Gal Hammer 2014-01-14 04:15:20 EST
A patch which updated both serial and balloon's inf files was posted.
Comment 10 Mike Cao 2014-03-27 20:44:08 EDT
Re-Test this issue on virtio-win-prewhql-75 

Actual Results:

Warnings on BALLOON display name is fixed ald . 

But it still shows following infos in the log file  

Running test on driver INF C:\Windows\Inf\oem1.inf 
Warning 3/20/2014 6:32:51.684 AM Driver package C:\Windows\Inf\oem1.inf does not use PnpLockdown directive in its version section. It is recommended to specify PnpLockdown = 1 in the version section. 
File:    Line: -1 
End Test 3/20/2014 6:32:51.684 AM DevFundInfTest::UsePnpLockdown 


Based on above ,this issue has not been fixed yet 
Reassign this issue
Comment 11 Gal Hammer 2014-03-30 04:08:59 EDT
Although the MSDN's documentation state that it is possible for the PnpLockdown value to be 0 to maintain backward compatibility, I've posted a set of patches which change the value to 1 for balloon, serial and rng.
Comment 12 Gal Hammer 2014-04-01 12:23:17 EDT
Vadim thinks that this change might affect the installer's behavior during an upgrade. Can you please verify it? Thanks.
Comment 13 Mike Cao 2014-04-13 23:10:13 EDT
(In reply to Gal Hammer from comment #12)
> Vadim thinks that this change might affect the installer's behavior during
> an upgrade. Can you please verify it? Thanks.

I tried driver upgrade from build71 to build79 ,did not find any issue
Comment 14 Min Deng 2014-04-20 23:23:58 EDT
   QE Re-test the bug on build 79 on win2012/2012R2/win832/win864 OS
Now,all warnings were gone from the logs and the job also could pass smoothly.so  the issue has been fixed.Thanks.
Best regards,
Min
Comment 15 Mike Cao 2014-04-20 23:25:11 EDT
Move status to VERiFied according to comment #14
Comment 17 Mike Cao 2014-05-28 02:33:12 EDT
Ronen , QE request thsi for rhel7.0.z 

Mike
Comment 18 Mike Cao 2014-05-28 03:25:11 EDT
(In reply to Mike Cao from comment #17)
> Ronen , QE request thsi for rhel7.0.z 
> 
> Mike

Sorry 

My bad .PM clone it ald
Comment 19 Ludek Smid 2014-06-13 05:24:44 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.