Bug 868250 - [create-failed] display appropriate error message when instance launch failes due to Availability Zone issues
[create-failed] display appropriate error message when instance launch failes...
Status: CLOSED DUPLICATE of bug 860484
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 06:42 EDT by Rehana
Modified: 2012-10-19 10:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-19 10:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2012-10-19 06:42:51 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Build and push image to ec2(rhel6.2, hwp:small-x86_64)
2.Create a cluster and mapped to "ec2-us-east-1: us-east-1a" region
3.tried to launch instance
  
Actual results:
Instance launch failed, instance moved to "create_failed" state 

Expected results:
It will be good to show the reason for the failure, rather than just marking it has create_failed.

Additional info:
rpm -qa | grep aeolus
aeolus-configserver-0.4.11-1.el6cf.noarch
rubygem-aeolus-cli-0.7.5-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.20-1.el6cf.noarch
aeolus-all-0.13.20-1.el6cf.noarch
aeolus-conductor-doc-0.13.20-1.el6cf.noarch
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-daemons-0.13.20-1.el6cf.noarch


----------------mock.log----------


<?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>Unsupported</Code><Message>The requested Availability Zone is currently constrained and we are no longer accepting new customer requests for t1/m1/c1/m2 instance types. Please retry your request by not specifying an Availability Zone or choosing us-east-1c, us-east-1d, us-east-1b.</Message></Error></Errors><RequestID>a217bab6-b0c2-45cb-93a2-463b39ee10a2</RequestID></Response> #####
W, [2012-10-19T05:43:03.565071 #1757]  WARN -- : ##### Aws::Ec2 request: ec2.us-east-1.amazonaws.com:443/?AWSAccessKeyId=AKIAJZG5XB3O6GU7O6SQ&Action=RunInstances&AddressingType=public&ImageId=ami-4807b921&InstanceType=m1.small&KeyName=ec2-CONFG_ec2_1350639781_key_70003410731300&MaxCount=1&MinCount=1&Placement.AvailabilityZone=us-east-1a&SignatureMethod=HmacSHA256&SignatureVersion=2&Timestamp=2012-10-19T09%3A43%3A03.000Z&Version=2010-08-31&Signature=DUPbrHYB63lurdt1tcoRMo3Hp%2BXHvB0x8bDtykOtvvs%3D ####
I, [2012-10-19T05:43:03.566143 #1757]  INFO -- : Closing HTTPS connection to ec2.us-east-1.amazonaws.com:443, reason: 'Aws::AWSErrorHandler: code: 400: 'Bad Request', probability: 10%'
thin server (localhost:3002) [deltacloud-mock][1757]: [NO HANDLED] Aws::AwsError: Unsupported: The requested Availability Zone is currently constrained and we are no longer accepting new customer requests for t1/m1/c1/m2 instance types. Please retry your request by not specifying an Availability Zone or choosing us-east-1c, us-east-1d, us-east-1b.
REQUEST=ec2.us-east-1.amazonaws.com:443/?AWSAccessKeyId=AKIAJZG5XB3O6GU7O6SQ&Action=RunInstances&AddressingType=public&ImageId=ami-4807b921&InstanceType=m1.small&KeyName=ec2-CONFG_ec2_1350639781_key_70003410731300&MaxCount=1&MinCount=1&Placement.AvailabilityZone=us-east-1a&SignatureMethod=HmacSHA256&SignatureVersion=2&Timestamp=2012-10-19T09%3A43%3A03.000Z&Version=2010-08-31&Signature=DUPbrHYB63lurdt1tcoRMo3Hp%2BXHvB0x8bDtykOtvvs%3D 
REQUEST ID=a217bab6-b0c2-45cb-93a2-463b39ee10a2 
/usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ses/../awsbase/awsbase.rb:572:in `request_info_impl'
/usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ec2/ec2.rb:177:in `request_info'
/usr/lib/ruby/gems/1.8/gems/aws-2.5.5/lib/ec2/ec2.rb:577:in `launch_instances'
/usr/share/deltacloud-core/lib/deltacloud/drivers/ec2/ec2_driver.rb:241:in `create_instance'
/usr/share/deltacloud-core/lib/deltacloud/base_driver/exceptions.rb:151:in `call'
/usr/share/deltacloud-core/lib/deltacloud/base_driver/exceptions.rb:151:in `safely'
/usr/share/deltacloud-core/lib/deltacloud/drivers/ec2/ec2_driver.rb:240:in `create_instance'
/usr/share/deltacloud-core/lib/deltacloud/server.rb:480
/usr/share/deltacloud-core/lib/sinatra/rabbit.rb:125:in `instance_eval'
/usr/share/deltacloud-core/lib/sinatra/rabbit.rb:125:in `POST /api/instances'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1151:in `call'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1151:in `compile!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:724:in `instance_eval'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:724:in `route_eval'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:708:in `route!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:758:in `process_route'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:755:in `catch'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:755:in `process_route'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:707:in `route!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:706:in `each'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:706:in `route!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:843:in `dispatch!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:644:in `call!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `instance_eval'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `invoke'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `catch'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:808:in `invoke'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:644:in `call!'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:629:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_syslog.rb:48:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_date.rb:31:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_accept.rb:149:in `call'
/usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/head.rb:9:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_driver_select.rb:45:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_matrix_params.rb:106:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_runtime.rb:36:in `call'
/usr/share/deltacloud-core/lib/sinatra/rack_etag.rb:41:in `call'
/usr/lib/ruby/gems/1.8/gems/rack-accept-0.4.3/lib/rack/accept/context.rb:22:in `call'
/usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/head.rb:9:in `call'
/usr/lib/ruby/gems/1.8/gems/rack-1.3.0/lib/rack/methodoverride.rb:24:in `call'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1272:in `call'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1303:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/sinatra-1.2.6/lib/sinatra/base.rb:1272:in `call'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:84:in `pre_process'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:82:in `catch'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:82:in `pre_process'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1060:in `call'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1060:in `spawn_threadpool'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057:in `initialize'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057:in `new'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1057:in `spawn_threadpool'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:1049:in `defer'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:54:in `process'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/connection.rb:42:in `receive_data'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run_machine'
/usr/lib/ruby/gems/1.8/gems/eventmachine-0.12.10/lib/eventmachine.rb:256:in `run'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/backends/base.rb:61:in `start'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/server.rb:159:in `start'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/controllers/controller.rb:86:in `start'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:185:in `send'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:185:in `run_command'
/usr/lib/ruby/gems/1.8/gems/thin-1.2.11/lib/thin/runner.rb:151:in `run!'
/usr/share/deltacloud-core/bin/deltacloudd:235
/usr/bin/deltacloudd:5:in `load'
/usr/bin/deltacloudd:5
thin server (localhost:3002) [deltacloud-mock][1757]: 127.0.0.1 - - [19/Oct/2012 05:43:03] "POST /api/instances HTTP/1.1" 500 6719 0.4829
I, [2012-10-19T05:46:58.622586 #1757]  INFO -- : New Aws::Ec2 using per_thread-connection mode
W, [2012-10-19T05:46:58.625017 #1757]  WARN -- : Rightscale::HttpConnection : request failure count: 1, exception: #<Errno::EPIPE: Broken pipe>
I, [2012-10-19T05:46:58.625126 #1757]  INFO -- : Opening new HTTPS connection to ec2.us-east-1.amazonaws.com:443
I, [2012-10-19T05:47:13.824210 #1757]  INFO -- : New Aws::Ec2 using per_thread-connection mode
W, [2012-10-19T05:47:13.829306 #1757]  WARN -- : Rightscale::HttpConnection : request failure count: 1, exception: #<Errno::EPIPE: Broken pipe>
I, [2012-10-19T05:47:13.838043 #1757]  INFO -- : Opening new HTTPS connection to ec2.us-east-1.amazonaws.com:443
I, [2012-10-19T05:47:37.284031 #1757]  INFO -- : New Aws::Ec2 using per_thread-connection mode
I, [2012-10-19T05:47:39.040527 #1757]  INFO -- : New Aws::Ec2 using per_thread-connection mode
I, [2012-10-19T05:47:39.043708 #1757]  INFO -- : Launching instance of image ami-4807b921 for AKIAJZG5XB3O6GU7O6SQ, key: -CONFIG-SERVER_ec2_1350640057_key_70003414665780, groups: 
W, [2012-10-19T05:47:39.045186 #1757]  WARN -- : Rightscale::HttpConnection : request failure count: 1, exception: #<Errno::EPIPE: Broken pipe>
I, [2012-10-19T05:47:39.045298 #1757]  INFO -- : Opening new HTTPS connection to ec2.us-east-1.amazonaws.com:443
W, [2012-10-19T05:47:39.427514 #1757]  WARN -- : ##### Aws::Ec2 returned an error: 400 Bad Request
<?xml version="1.0" encoding="UTF-8"?>
Comment 2 Jan Provaznik 2012-10-19 06:57:35 EDT
In the this case error message is not saved because it's too long (>255), easiest would be trim the message in app/util/taskomatic.rb#create_failure_events method
Comment 3 Dave Johnson 2012-10-19 10:16:05 EDT

*** This bug has been marked as a duplicate of bug 860484 ***

Note You need to log in before you can comment on or make changes to this bug.