Bug 868278 - ValueError: ('invalid size specification', '-1.000000 MB')
ValueError: ('invalid size specification', '-1.000000 MB')
Status: CLOSED DUPLICATE of bug 864766
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:b71e166799d86f1ba51162e00fe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 07:55 EDT by Petr Schindler
Modified: 2012-11-05 15:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 15:09:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (779.23 KB, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: product (6 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: type (9 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: ifcfg.log (631 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: storage.log (548.31 KB, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: version (11 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: environ (761 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: anaconda.log (41.10 KB, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: syslog (121.09 KB, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: packaging.log (4.29 KB, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: release (24 bytes, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details
File: program.log (32.18 KB, text/plain)
2012-10-19 07:55 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-10-19 07:55:15 EDT
Description of problem:
I tried to change the capacity of new volume from 160 GB to 140. I did it in manual partitioning.

Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 79, in _parseSpec
:    raise ValueError("invalid size specification", spec)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/size.py", line 137, in __new__
:    self = Decimal.__new__(cls, value=_parseSpec(spec))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1081, in _save_right_side
:    % str(Size(spec="%f MB" % device.size)).upper())
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1948, in on_apply_clicked
:    self._save_right_side(self._current_selector)
:ValueError: ('invalid size specification', '-1.000000 MB')
Comment 1 Petr Schindler 2012-10-19 07:55:21 EDT
Created attachment 629981 [details]
File: anaconda-tb
Comment 2 Petr Schindler 2012-10-19 07:55:24 EDT
Created attachment 629982 [details]
File: product
Comment 3 Petr Schindler 2012-10-19 07:55:26 EDT
Created attachment 629983 [details]
File: type
Comment 4 Petr Schindler 2012-10-19 07:55:28 EDT
Created attachment 629984 [details]
File: ifcfg.log
Comment 5 Petr Schindler 2012-10-19 07:55:31 EDT
Created attachment 629985 [details]
File: storage.log
Comment 6 Petr Schindler 2012-10-19 07:55:34 EDT
Created attachment 629986 [details]
File: version
Comment 7 Petr Schindler 2012-10-19 07:55:36 EDT
Created attachment 629987 [details]
File: environ
Comment 8 Petr Schindler 2012-10-19 07:55:38 EDT
Created attachment 629988 [details]
File: anaconda.log
Comment 9 Petr Schindler 2012-10-19 07:55:40 EDT
Created attachment 629989 [details]
File: syslog
Comment 10 Petr Schindler 2012-10-19 07:55:42 EDT
Created attachment 629990 [details]
File: hashmarkername
Comment 11 Petr Schindler 2012-10-19 07:55:44 EDT
Created attachment 629991 [details]
File: packaging.log
Comment 12 Petr Schindler 2012-10-19 07:55:46 EDT
Created attachment 629992 [details]
File: cmdline_file
Comment 13 Petr Schindler 2012-10-19 07:55:48 EDT
Created attachment 629993 [details]
File: release
Comment 14 Petr Schindler 2012-10-19 07:55:50 EDT
Created attachment 629994 [details]
File: program.log
Comment 15 Jesse Keating 2012-10-19 13:03:45 EDT
A bunch of code has changed around there recently.  Best to test with Beta TC5 when it becomes available.
Comment 16 Adam Williamson 2012-11-05 15:09:27 EST
dlehman believes all these '-1.000000 MB' bugs are the same.

*** This bug has been marked as a duplicate of bug 864766 ***

Note You need to log in before you can comment on or make changes to this bug.