Bug 868279 - [abrt] ibus-1.4.99.20120914-2.fc17: main.py:277:__init_ui:AttributeError: 'NoneType' object has no attribute 'connect'
[abrt] ibus-1.4.99.20120914-2.fc17: main.py:277:__init_ui:AttributeError: 'No...
Status: CLOSED DUPLICATE of bug 859585
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:c214d00979668a35acb9c0be187...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 07:57 EDT by netroby
Modified: 2012-10-21 22:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-21 22:23:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (264 bytes, text/plain)
2012-10-19 07:57 EDT, netroby
no flags Details

  None (edit)
Description netroby 2012-10-19 07:57:18 EDT
Version-Release number of selected component:
ibus-1.4.99.20120914-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py ibus-setup
kernel:         3.6.2-4.fc17.x86_64

backtrace:
:main.py:277:__init_ui:AttributeError: 'NoneType' object has no attribute 'connect'
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/main.py", line 679, in <module>
:    setup = Setup()
:  File "/usr/share/ibus/setup/main.py", line 83, in __init__
:    self.__init_ui()
:  File "/usr/share/ibus/setup/main.py", line 277, in __init_ui
:    self.__config.connect("value-changed", self.__config_value_changed_cb)
:AttributeError: 'NoneType' object has no attribute 'connect'
:
:Local variables in innermost frame:
:self: <__main__.Setup object at 0x14a7b10>
Comment 1 netroby 2012-10-19 07:57:22 EDT
Created attachment 629995 [details]
File: core_backtrace
Comment 2 fujiwara 2012-10-21 22:23:36 EDT
Please use ibus-1.4.99.20121006-2.fc17 .

*** This bug has been marked as a duplicate of bug 859585 ***
Comment 3 netroby 2012-10-21 22:25:03 EDT
Thanks, i am using Fcitx now. 
leave iBus as it be.

Note You need to log in before you can comment on or make changes to this bug.