This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 868311 - RFE - Floppyinject hook does not work under 3.1
RFE - Floppyinject hook does not work under 3.1
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: vdsm-hook-floppyinject (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity medium
: 1.1.1
: ---
Assigned To: Michal Fojtik
Rehana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 09:29 EDT by Michal Fojtik
Modified: 2012-11-14 15:17 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
It seems like the floppyinject VDSM hook we used in CloudForms 1.0 to deliver user-data into instance no longer works under RHEV-M 3.1. **We'll need the appropriate Doc text in this section for docs to create a release note.**
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 14:27:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Fojtik 2012-10-19 09:29:15 EDT
Description of problem:

After conversation with Shahar, it seems like the floppyinject VDSM hook we used in CloudForms 1.0 to deliver user-data into instance does not longer work under RHEV-M 3.1. According to Shahar, the internal API changed:

<cite>
there is code changes the first that I see is the utils.execCmd() now you
need to change it to hooking.execCmd() (parameters are the same)
and you need to remove the 'import utils' and it suppose to work.
</cite>

It is possible to have this fixed in a way that it will not break the backward compatibility? (I mean it will continue to work on <3.0 but also work on 3.1).

Version-Release number of selected component (if applicable):

3.1

Steps to Reproduce:
1. Install vdsm-hook-floppyinject[1]
2. Specify the custom_properties when creating a new VM
3. Hook does not work.
  
[1] vdsm-hook-floppyinject-1.0-9.el6_2
Comment 1 Andrew Cathrow 2012-10-19 12:43:06 EDT
Moving to vdsm-hook-floppyinject component on cloudforms
Comment 3 jrd 2012-10-19 12:52:53 EDT
(In reply to comment #1)
> Moving to vdsm-hook-floppyinject component on cloudforms

My understanding was that the root cause of the breakage is that the internal api changed between 3.0 and 3.1.  See the citation in the original description.

Perhaps we're saying that that internal api was never documented, and we shouldn't have expected it to stay stable?  In that case, I concur; this belongs to the floppyinject hook.
Comment 4 Andrew Cathrow 2012-10-19 12:56:17 EDT
(In reply to comment #3)
> (In reply to comment #1)
> > Moving to vdsm-hook-floppyinject component on cloudforms
> 
> My understanding was that the root cause of the breakage is that the
> internal api changed between 3.0 and 3.1.  See the citation in the original
> description.
> 
> Perhaps we're saying that that internal api was never documented, and we
> shouldn't have expected it to stay stable?  In that case, I concur; this
> belongs to the floppyinject hook.

The 3.1 syntax works with 3.0 - I'd recommend moving to that now.
https://bugzilla.redhat.com/show_bug.cgi?id=835606
Comment 5 jrd 2012-10-19 13:00:53 EDT
Ah, ok, that makes sense.  We weren't using it quite right.

mfojtik joev does this info impact your assessment of what should be done to get this support sorted out in CF 1.1?
Comment 10 Michal Fojtik 2012-10-24 04:48:55 EDT
I prepared a patch to fix this issue:

https://github.com/aeolusproject/vdsm-hook-floppyinject/pull/2

I tested this on RHEVM 3.1 (si21) and it works perfectly. Can somebody do a testing for 3.0?
Comment 11 Michal Fojtik 2012-10-24 04:49:45 EDT
(In reply to comment #10)
> I prepared a patch to fix this issue:
> 
> https://github.com/aeolusproject/vdsm-hook-floppyinject/pull/2
> 
> I tested this on RHEVM 3.1 (si21) and it works perfectly. Can somebody do a
> testing for 3.0?

Shahar can you please check my changes? Just to be sure I did not blow up something :-)
Comment 12 Itamar Heim 2012-10-24 09:28:19 EDT
I'd make sure the hook requires the version of vdsm which added the support for this in 3.0.z per bug 835606 (vdsm-4.9-113.2)
Comment 13 Michal Fojtik 2012-10-24 10:02:52 EDT
(In reply to comment #12)
> I'd make sure the hook requires the version of vdsm which added the support
> for this in 3.0.z per bug 835606 (vdsm-4.9-113.2)

I thought that this change will be backward compatible and from what I understand from Andrew comment, we were using it wrong.
Comment 14 Michal Fojtik 2012-10-24 10:12:06 EDT
Btw. the patch was merged to:

https://github.com/aeolusproject/vdsm-hook-floppyinject

Re C13: I found the errata, so taking this comment back ;-)
Comment 15 Tomas Hrcka 2012-10-24 10:37:34 EDT
I have tested Michal's patch on RHEVM 3.1 and it worked perfectly.
Comment 17 Joe Vlcek 2012-11-12 14:15:22 EST
A patch to DeltaCloud 0.5.0 provides the needed functionality
without the need to use the floppy inject hook.

I believe since there is now a better way to inject user data on RHEVm3.1,
the floppy hook is not required for RHEVm3.1 therefor fixing this
bug is not necessary.

I believe this bug should be close.
Comment 18 Michal Fojtik 2012-11-12 14:27:10 EST
Joe is right, this bug fix the bug in vdsm hook however this is not longer a preferred way how to inject data to VM for RHEVM 3.1. Closing this bug as NOTFIX seems appropriate for me.

Also if someone in future will be interested in using this method, the is pushed in GIT repo.

Note You need to log in before you can comment on or make changes to this bug.