Bug 868369 - no prompt for password to encrypted disk - boot sequence hangs
no prompt for password to encrypted disk - boot sequence hangs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 11:32 EDT by John Ellson
Modified: 2012-10-29 11:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 11:00:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2012-10-19 11:32:06 EDT
Description of problem:
Boot hangs on system with encrypted disk.

I didn't see a prompt ... sometimes its hard to see because its not always the last message on the screen .. but entering the password like normal had no effect.

Version-Release number of selected component (if applicable):
kernel-3.6.2-2.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1.reboot
2.
3.
  
Actual results:
System hung during boot sequence, at roughly the point where it should be asking for the password for the encrypted file system.

Expected results:
Normal boot of system with encrypted file system


Additional info:
kernel-3.6.1-1.fc18.x86_64    works OK
Comment 1 Justin M. Forbes 2012-10-24 13:00:15 EDT
I don't see anything in 3.6.2 that would lead to this, it is possible that your initramfs got mangled in creation? Does installing 3.6.3 currently in updates-testing fix this for you?
Comment 2 John Ellson 2012-10-24 13:36:06 EDT
Before I reboot....   isn't kernel-3.6.3-3.fc18 the one with the reported EXT4 FS corruption problem?
Comment 3 John Ellson 2012-10-28 16:56:30 EDT
FS corruption problem sounds rare, so I took the risk and rebooted...

Prompt for FS encrytion passwd is OK with kernel-3.6.3-3.fc18.x86_64

You can close this.  Thanks,

Note You need to log in before you can comment on or make changes to this bug.