Bug 868380 - [abrt]: WARNING: at drivers/gpu/drm/i915/intel_display.c:1225 assert_pipe+0x94/0xa0 [i915](): TAINTED G W
[abrt]: WARNING: at drivers/gpu/drm/i915/intel_display.c:1225 assert_pipe+0x9...
Status: CLOSED DUPLICATE of bug 866472
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:b78e04db870a2997c1385acdbbc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 12:36 EDT by aawasthi
Modified: 2013-01-04 17:01 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 17:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aawasthi 2012-10-19 12:36:36 EDT
Description of problem:
Upgrade to kernels 3.6.1-1.fc17.i686.PAE and 3.6.2-4.fc17.i686.PAE caused this problem. No display appears. 3.5.4-2 boots normally.

I pass on agp=off to kernel. I have two display adaptor, nvidia and intel, and this is required to boot from nvidia.


Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.2-4.fc17.i686.PAE root=/dev/mapper/vg-lv_root ro rd.md=0 rd.dm=0 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rd.lvm.lv=VolGroup14/lv_swap rd.lvm.lv=vg/lv_root rd.luks=0 rd.lvm.lv=vg/lv_swap LANG=en_IN.UTF-8 rhgb quiet agp=off
kernel:         3.6.2-4.fc17.i686.PAE

kernel_tainted_long:
:Proprietary module has not been loaded.
:Taint on warning.

backtrace:
:WARNING: at drivers/gpu/drm/i915/intel_display.c:1225 assert_pipe+0x94/0xa0 [i915]()
:Hardware name:  
:pipe A assertion failure (expected on, current off)
:Modules linked in: i915(+) nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
:Pid: 171, comm: udevd Tainted: G        W    3.6.2-4.fc17.i686.PAE #1
:Call Trace:
: [<c044b692>] warn_slowpath_common+0x72/0xa0
: [<f7f37f54>] ? assert_pipe+0x94/0xa0 [i915]
: [<f7f37f54>] ? assert_pipe+0x94/0xa0 [i915]
: [<c044b763>] warn_slowpath_fmt+0x33/0x40
: [<f7f37f54>] assert_pipe+0x94/0xa0 [i915]
: [<f7f3ce19>] intel_crtc_disable+0x59/0x90 [i915]
: [<f83ab2af>] drm_helper_disable_unused_functions+0xef/0x140 [drm_kms_helper]
: [<f83aae03>] drm_fb_helper_initial_config+0x23/0x260 [drm_kms_helper]
: [<c054357f>] ? kmem_cache_alloc_trace+0x10f/0x130
: [<c05438ee>] ? __kmalloc+0x12e/0x180
: [<c054357f>] ? kmem_cache_alloc_trace+0x10f/0x130
: [<f83a9ea0>] ? drm_fb_helper_init+0xb0/0x180 [drm_kms_helper]
: [<f83a9ea0>] ? drm_fb_helper_init+0xb0/0x180 [drm_kms_helper]
: [<f83a9fa7>] ? drm_fb_helper_single_add_all_connectors+0x37/0xc0 [drm_kms_helper]
: [<f83a9fa7>] ? drm_fb_helper_single_add_all_connectors+0x37/0xc0 [drm_kms_helper]
: [<f83a9fa7>] ? drm_fb_helper_single_add_all_connectors+0x37/0xc0 [drm_kms_helper]
: [<f7f54916>] intel_fbdev_init+0x76/0xb0 [i915]
: [<f7f19473>] i915_driver_load+0xa53/0xb90 [i915]
: [<f7f16ce0>] ? i915_switcheroo_set_state+0xa0/0xa0 [i915]
: [<f7e4dd7b>] ? drm_sysfs_device_add+0x7b/0xb0 [drm]
: [<f7e4a4f8>] ? drm_get_minor+0x238/0x2c0 [drm]
: [<f7e4c7ab>] drm_get_pci_dev+0x13b/0x270 [drm]
: [<f7f5f8f7>] i915_pci_probe+0x4b/0x55 [i915]
: [<c06a0440>] pci_device_probe+0xa0/0x150
: [<c0753a69>] driver_probe_device+0x79/0x350
: [<c06a013e>] ? pci_match_device+0x9e/0xb0
: [<c0753dd1>] __driver_attach+0x91/0xa0
: [<c0753d40>] ? driver_probe_device+0x350/0x350
: [<c0751fb2>] bus_for_each_dev+0x42/0x80
: [<c075349e>] driver_attach+0x1e/0x20
: [<c0753d40>] ? driver_probe_device+0x350/0x350
: [<c075314f>] bus_add_driver+0x17f/0x290
: [<c06a04f0>] ? pci_device_probe+0x150/0x150
: [<c06a04f0>] ? pci_device_probe+0x150/0x150
: [<c07543ca>] driver_register+0x6a/0x160
: [<c04403be>] ? change_page_attr_set_clr+0x2fe/0x3b0
: [<f7f89000>] ? 0xf7f88fff
: [<f7f89000>] ? 0xf7f88fff
: [<c069f472>] __pci_register_driver+0x42/0xb0
: [<f7f89000>] ? 0xf7f88fff
: [<f7e4c9dd>] drm_pci_init+0xfd/0x110 [drm]
: [<f7f89000>] ? 0xf7f88fff
: [<f7f8905e>] i915_init+0x5e/0x60 [i915]
: [<c0403112>] do_one_initcall+0x112/0x160
: [<c04a6192>] ? set_section_ro_nx+0x62/0x80
: [<c04a8b94>] sys_init_module+0x1004/0x1d80
: [<c052d906>] ? do_mmap_pgoff+0x1e6/0x2d0
: [<c097945f>] sysenter_do_call+0x12/0x28
Comment 1 aawasthi 2012-12-18 08:46:54 EST
I wonder if bugs 879909 and 887536 are related to this bug. It goes not occur in 3.5.4-2.i686PAE in a fully updated computer.
Comment 2 aawasthi 2012-12-18 08:48:47 EST
Sorry for the typo; "does" in place of "goes".(In reply to comment #1)

> I wonder if bugs 879909 and 887536 are related to this bug. It goes not
> occur in 3.5.4-2.i686PAE in a fully updated computer.
Comment 3 Adam Jackson 2013-01-04 17:01:12 EST

*** This bug has been marked as a duplicate of bug 866472 ***

Note You need to log in before you can comment on or make changes to this bug.