Bug 868432 - kernel-devel includes a blank linux/version.h
kernel-devel includes a blank linux/version.h
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 16:33 EDT by Josh Stone
Modified: 2012-10-30 09:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 09:37:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Stone 2012-10-19 16:33:57 EDT
Description of problem:
Per https://lists.fedoraproject.org/pipermail/kernel/2012-October/003976.html

Kernel 3.7 has moved linux/version.h to the uapi path, but kernel.spec has a line that touches the timestamp on the old path.  (see also bug 854689)  Since -Iinclude comes before -Iinclude/generated/uapi in the build flags, then the touched-empty file is the one that wins.

Version-Release number of selected component (if applicable):
kernel-devel-3.7.0-0.rc1.git2.1.fc19.x86_64

This is an issue for any external module that needs to make version checks, which is approximately all of them...

If that "touch" is still needed, then it should refer to the new path, and consider using "-c" to make sure it never creates new files like this.
Comment 1 Josh Boyer 2012-10-30 09:37:16 EDT
This should be fixed in rawhide now.

Note You need to log in before you can comment on or make changes to this bug.