Bug 868484 - The Getting Started Guide has two problems in the section 5.1 VNC consoles.
The Getting Started Guide has two problems in the section 5.1 VNC consoles.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
1.0 (Essex)
All Linux
unspecified Severity low
: ---
: 2.0 Folsom
Assigned To: Bruce Reeler
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 04:40 EDT by SAITO Hideki
Modified: 2014-10-30 18:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 19:36:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description SAITO Hideki 2012-10-20 04:40:48 EDT
Description of problem:

The Getting Started Guide has two problems in the section 5.1 VNC consoles.

1. The openstack-nova-novncproxy installation is necessary.
2. We should use an openstack-config command to set up nova.conf. 


Version-Release number of selected component (if applicable):

[Document Name]
Red Hat OpenStack Preview - Getting Started Guide

[Document Section]
5.1 VNC consoles

[URL]
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack_Preview/1/html/Getting_Started_Guide/ch05.html

How reproducible:

N/A

Steps to Reproduce:

I checked that the package is not installed

$ rpm -q openstack-nova-novncproxy
package openstack-nova-novncproxy is not installed

Actual results:

N/A

Expected results:

1. The openstack-nova-novncproxy installation is necessary.
  $ sudo yum install openstack-nova-novncproxy

2. We should use an openstack-config command to set up nova.conf.
  I executed openstack-config command as below.

  $ sudo openstack-config --set /etc/nova/nova.conf DEFAULT novncproxy_host 0.0.0.0
  $ sudo openstack-config --set /etc/nova/nova.conf DEFAULT novncproxy_port 6080
  $ sudo openstack-config --set /etc/nova/nova.conf DEFAULT novncproxy_base_url $NOVNCPROXY_FQDN:6080/vnc_auto.html
  $ sudo openstack-config --set /etc/nova/nova.conf DEFAULT vnc_enabled true
  $ sudo openstack-config --set /etc/nova/nova.conf DEFAULT vncserver_listen 127.0.0.1
  $ sudo openstack-config --set /etc/nova/nova.conf DEFAULT vncserver_proxyclient_address 127.0.0.1

Additional info:

N/A
Comment 2 Bruce Reeler 2012-10-22 02:45:55 EDT
Issue 1, openstack-nova-novncproxy installation, has already been corrected. Original bug was reported in BZ856671.
Comment 3 SAITO Hideki 2012-10-22 04:21:58 EDT
> Issue 1, openstack-nova-novncproxy installation, has already been corrected. Original bug was reported in BZ856671.

oh...I'm sorry, I had to check it first:)
Comment 4 Bruce Reeler 2012-10-24 21:28:21 EDT
No problem Saito! Better to report twice than miss a bug!
Comment 5 Bruce Reeler 2012-12-13 02:12:51 EST
Fixed.
Issue 1 was duplicate of BZ856671.

Issue 2 was corrected as part of an update to Chap 8.1 "VNC Consoles".

Note You need to log in before you can comment on or make changes to this bug.