Bug 868590 - build error: File not found (pesign.conf)
build error: File not found (pesign.conf)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pesign (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-20 21:25 EDT by Mr-4
Modified: 2012-10-22 10:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 10:36:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mr-4 2012-10-20 21:25:08 EDT
Description of problem:
During build (using srpm) I get the following error:
RPM build errors:
    File not found: /builddir/build/BUILDROOT/pesign-0.99-3.fc17.x86_64/usr/lib/tmpfiles.d/pesign.conf


Version-Release number of selected component (if applicable):
0.99, *but* with the newest source from git (the 0.99 version can't get this far as I am getting other errors)

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb pesign.spec, using the latest git source
2.
3.
  
Actual results:
The above error

Expected results:
Compilation and creating the rpm to succeed

Additional info:
The only reference to this file is in the .spec file as follows:
%{_prefix}/lib/tmpfiles.d/pesign.conf
but that file is nowhere to be seen in the sources, nor is it created during build. A "workaround" (if one could call it that!) is to delete that reference in order for the build to succeed.
Comment 1 Mr-4 2012-10-21 20:15:15 EDT
This seems to have been caused by compilation of MASTER branch sources (from git, as I did not have any joy with v0.99). 

When I managed to finally compile v0.99 (see Comment #2 on Bug 868591) this is no longer an issue and this file is now generated and placed in its place in the resulting rpm, so this bug can now be closed.

Note You need to log in before you can comment on or make changes to this bug.