Bug 868655 - Error messages when installing the minimum policy
Error messages when installing the minimum policy
Status: CLOSED DUPLICATE of bug 868657
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 09:42 EDT by Bruno Wolff III
Modified: 2012-10-25 04:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 04:58:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-10-21 09:42:12 EDT
Description of problem:
Running Transaction
  Installing : selinux-policy-minimum-3.11.1-41.fc18.noarch                 1/1 
/var/tmp/rpm-tmp.J5nXLL: line 34:   632 Segmentation fault      /usr/sbin/semanage -S minimum -i -  <<__eof
login -m  -s unconfined_u -r s0-s0:c0.c1023 __default__
login -m  -s unconfined_u -r s0-s0:c0.c1023 root
__eof

libsepol.print_missing_requirements: webadm's global requirements were not met: type/attribute httpd_sys_content_t (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
/usr/sbin/semodule:  Failed!

I am running targeted when doing the install. I don't use the minimum policy, so I don't know if it is actually broken.
Comment 1 Miroslav Grepl 2012-10-24 14:04:22 EDT
If you execute

# yum reinstall selinux-policy-minimum

does it blow up?
Comment 2 Bruno Wolff III 2012-10-24 16:38:24 EDT
[root@bruno bruno]# yum reinstall selinux-policy-minimum
Loaded plugins: aliases, changelog, keys, list-data, merge-conf, post-
              : transaction-actions, priorities, protectbase, remove-with-
              : leaves, rpm-warm-cache, show-leaves, tmprepo, tsflags, verify,
              : versionlock
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package selinux-policy-minimum.noarch 0:3.11.1-43.fc18 will be reinstalled
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch        Version               Repository  Size
================================================================================
Reinstalling:
 selinux-policy-minimum      noarch      3.11.1-43.fc18        local      3.8 M

Transaction Summary
================================================================================
Reinstall  1 Package

Total download size: 3.8 M
Installed size: 15 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : selinux-policy-minimum-3.11.1-43.fc18.noarch                 1/1 
libsepol.sepol_context_from_string: malformed context "" (Invalid argument).
libsepol.sepol_context_from_string: could not construct context from string (Invalid argument).
libsepol.sepol_context_from_string: malformed context "" (Invalid argument).
libsepol.sepol_context_from_string: could not construct context from string (Invalid argument).
  Verifying  : selinux-policy-minimum-3.11.1-43.fc18.noarch                 1/1 

Installed:
  selinux-policy-minimum.noarch 0:3.11.1-43.fc18                                

Complete!
Comment 3 Miroslav Grepl 2012-10-25 04:58:51 EDT

*** This bug has been marked as a duplicate of bug 868657 ***

Note You need to log in before you can comment on or make changes to this bug.