Bug 868796 - glusterd crashed
glusterd crashed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 03:27 EDT by Rachana Patel
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:27:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dump (498.90 KB, application/x-gzip)
2012-10-22 03:27 EDT, Rachana Patel
no flags Details

  None (edit)
Description Rachana Patel 2012-10-22 03:27:01 EDT
Created attachment 631293 [details]
dump

Description of problem:
glusterd crashed (might be on volume start)

Version-Release number of selected component (if applicable):
glusterfs 3git built on Oct 22 2012 09:46:02

[root@Rhsgit2 glusterfs]# git log
commit cf63a76ca03240eb617ca5bd2aa9b3f7abe7b6a4
Author: Emmanuel Dreyfus <manu@netbsd.org>
Date:   Sat Oct 20 19:30:06 2012 +0200


How reproducible:


Steps to Reproduce:
1. start glusterd on all peers.
2. checked 'gluster p s' - servers are connected
3. execute volume creation from another server

[root@rhsgit1 glusterfs]# gluster volume create san_22 10.70.35.107:/home/san_22_1 10.70.35.107:/home/san_22_2 10.70.35.71:/home/san_22_2  10.70.35.71:/home/san_22_1
volume create: san_22: failed: Host 10.70.35.71 not connected

volume creation failed.

4. Check glusterd status on not connected server
found glusterd crashed

  
Actual results:


Expected results:


Additional info:

(gdb) bt
#0  0x00007ff7925dfb49 in list_add_tail (new=0x1da50d0, head=0x1da8d18)
    at list.h:43
#1  0x00007ff7925e040f in __run (task=0x1da50d0) at syncop.c:44
#2  0x00007ff7925e0666 in synctask_wake (task=0x1da50d0) at syncop.c:113
#3  0x00007ff78edf1916 in gd_syncop_mgmt_unlock_cbk (req=0x1b8fe3c, 
    iov=0x1b8fe7c, count=1, myframe=0x7ff7911cd79c) at glusterd-syncop.c:185
#4  0x00007ff79237e57e in rpc_clnt_handle_reply (clnt=0x1b8f350, 
    pollin=0x1b8dba0) at rpc-clnt.c:775
#5  0x00007ff79237e915 in rpc_clnt_notify (trans=0x1b989f0, 
    mydata=0x1b8f380, event=RPC_TRANSPORT_MSG_RECEIVED, data=0x1b8dba0)
    at rpc-clnt.c:894
#6  0x00007ff79237af8d in rpc_transport_notify (this=0x1b989f0, 
    event=RPC_TRANSPORT_MSG_RECEIVED, data=0x1b8dba0) at rpc-transport.c:495
#7  0x00007ff78eaf1c59 in socket_event_poll_in (this=0x1b989f0)
    at socket.c:1986
#8  0x00007ff78eaf2108 in socket_event_handler (fd=15, idx=1, 
    data=0x1b989f0, poll_in=1, poll_out=0, poll_err=0) at socket.c:2098
#9  0x00007ff7925f96bd in event_dispatch_epoll_handler (
    event_pool=0x1b54ea0, events=0x1b668a0, i=0) at event-epoll.c:384
#10 0x00007ff7925f98ac in event_dispatch_epoll (event_pool=0x1b54ea0)
    at event-epoll.c:445
#11 0x00007ff7925d0dcb in event_dispatch (event_pool=0x1b54ea0)
    at event.c:113
#12 0x00000000004083cb in main (argc=2, argv=0x7fff58648598)
    at glusterfsd.c:1883
Comment 2 Amar Tumballi 2012-12-21 02:55:00 EST
fixed in latest qa releases.
Comment 3 Rachana Patel 2013-05-08 02:46:33 EDT
verified with -3.4.0.4rhs-1.el6rhs.x86_64,not able to reproduce. Hence changing status to verified

Note You need to log in before you can comment on or make changes to this bug.