Bug 868937 - 3.0.z - [rhevm-dwh] - Duplicate rows in Views
3.0.z - [rhevm-dwh] - Duplicate rows in Views
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.0.8
Assigned To: Yaniv Lavi
David Botzer
infra
: ZStream
Depends On: 866492
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 09:59 EDT by Idith Tal-Kohen
Modified: 2016-02-10 14:21 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the virtual machine hourly history view and the virtual machine daily history view in the engine database contained duplicated records with the same history identifiers. Duplicated history identifiers distort historical data. The views were corrected so that each entry has a unique history identifier. The statistics contained in the views are no longer prone to distortion caused by duplicated history identifiers.
Story Points: ---
Clone Of: 866492
Environment:
Last Closed: 2012-11-27 14:57:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dbotzer: needinfo-


Attachments (Terms of Use)
dup (53.22 KB, image/png)
2012-10-25 01:59 EDT, David Botzer
no flags Details

  None (edit)
Comment 3 Stephen Gordon 2012-10-24 15:40:28 EDT
I set a NEEDINFO on Bug # 843468 to find out what the difference between the two is.
Comment 4 David Botzer 2012-10-25 01:58:32 EDT
Not Fixed, 3.1/si22.1
clean installation of si22 & si22.1, One entity of a kind ran for 24H

v3_1_vm_hourly_history_view

16;"2012-10-25 05:00:00+02"
16;"2012-10-25 05:00:00+02"
15;"2012-10-25 04:00:00+02"
15;"2012-10-25 04:00:00+02"

See pic

Not Fixed, 3.1/si22.1
Comment 5 David Botzer 2012-10-25 01:59:38 EDT
Created attachment 633169 [details]
dup
Comment 6 Itamar Heim 2012-10-25 03:22:56 EDT
this is a 3.0.z bug, testing should be done on 3.0 (though i'd wait for the fix for the 3.1 bug first)
Comment 8 David Botzer 2012-11-06 07:30:36 EST
which Build for 3.0 is it fixed ?
Comment 9 David Botzer 2012-11-07 02:41:39 EST
Not Fixed, 3.0/ic158.1

In v3_0_vm_hourly_history_view & v3_0_vm_daily_history_view - I have triple duplicate rows,

Please advise before I reopen,

v3_0_vm_hourly_history_view --
128283;"2012-11-07 06:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;60.00;13
128283;"2012-11-07 06:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;60.00;13
128283;"2012-11-07 06:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;60.00;13

v3_0_vm_daily_history_view --
22062;"2012-11-04 00:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;1451.00;13
22062;"2012-11-04 00:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;1451.00;13
22062;"2012-11-04 00:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;1451.00;13
Comment 10 Yaniv Lavi 2012-11-07 04:04:06 EST
(In reply to comment #9)
> Not Fixed, 3.0/ic158.1
> 
> In v3_0_vm_hourly_history_view & v3_0_vm_daily_history_view - I have triple
> duplicate rows,
> 
> Please advise before I reopen,
> 
> v3_0_vm_hourly_history_view --
> 128283;"2012-11-07
> 06:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;60.00;13
> 128283;"2012-11-07
> 06:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;60.00;13
> 128283;"2012-11-07
> 06:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;60.00;13
> 
> v3_0_vm_daily_history_view --
> 22062;"2012-11-04
> 00:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;1451.00;13
> 22062;"2012-11-04
> 00:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;1451.00;13
> 22062;"2012-11-04
> 00:00:00+02";"735e4102-9c68-4633-9b97-1daa6f79c14b";1;1451.00;13

rpm version please.
Comment 11 David Botzer 2012-11-08 00:52:07 EST
Why am I "Need Info" ?

I tested ,3.0/ic158.1
rhevm-reports-server-3.0.8-1.noarch
rhevm-reports-3.0.8-1.noarch
rhevm-reports-dwh-3.0.8-1.noarch
Comment 12 David Botzer 2012-11-08 03:19:05 EST
Not Fixed, 3.0/ic158.1
rhevm-reports-server-3.0.8-1.noarch
rhevm-reports-3.0.8-1.noarch
rhevm-reports-dwh-3.0.8-1.noarch
Comment 13 David Botzer 2012-11-13 05:59:27 EST
Fixed, 3.0/ic158.2
rhevm-reports-server-3.0.8-2.noarch
rhevm-reports-3.0.8-2.noarch
rhevm-reports-dwh-3.0.8-2.noarch
Fixed, 3.0/ic158.2
Comment 15 errata-xmlrpc 2012-11-27 14:57:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1497.html

Note You need to log in before you can comment on or make changes to this bug.