Bug 868946 - SELinux is preventing rpc.idmapd from 'read' accesses on the file /etc/samba/smb.conf.
SELinux is preventing rpc.idmapd from 'read' accesses on the file /etc/samba/...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:04c2fcd55935ef407bbab2f5102...
:
: 868948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 10:16 EDT by Mahmoud youssif
Modified: 2012-11-19 21:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 21:58:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mahmoud youssif 2012-10-22 10:16:17 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.11-1.fc16.i686
time:           Mon 22 Oct 2012 04:12:53 PM EET

description:
:SELinux is preventing rpc.idmapd from 'read' accesses on the file /etc/samba/smb.conf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rpc.idmapd should be allowed read access on the smb.conf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpc.idmapd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rpcd_t:s0
:Target Context                system_u:object_r:samba_etc_t:s0
:Target Objects                /etc/samba/smb.conf [ file ]
:Source                        rpc.idmapd
:Source Path                   rpc.idmapd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           nfs-utils-1.2.5-8.fc16.i686
:Target RPM Packages           samba-common-3.6.6-88.fc16.i686
:Policy RPM                    selinux-policy-3.10.0-91.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.11-1.fc16.i686 #1
:                              SMP Sun Sep 16 14:41:18 UTC 2012 i686 i686
:Alert Count                   7
:First Seen                    Sun 20 May 2012 11:35:17 AM EET
:Last Seen                     Sun 14 Oct 2012 01:15:19 PM EET
:Local ID                      ccc71a88-f665-41d2-987b-aa7e884cbccf
:
:Raw Audit Messages
:type=AVC msg=audit(1350213319.631:30): avc:  denied  { read } for  pid=1142 comm="rpc.idmapd" name="smb.conf" dev="sda3" ino=3680093 scontext=system_u:system_r:rpcd_t:s0 tcontext=system_u:object_r:samba_etc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1350213319.631:30): arch=i386 syscall=open success=no exit=EACCES a0=b7b751a0 a1=8000 a2=0 a3=b7b75218 items=0 ppid=1 pid=1142 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rpc.idmapd exe=/usr/sbin/rpc.idmapd subj=system_u:system_r:rpcd_t:s0 key=(null)
:
:Hash: rpc.idmapd,rpcd_t,samba_etc_t,file,read
:
:audit2allow
:
:#============= rpcd_t ==============
:allow rpcd_t samba_etc_t:file read;
:
:audit2allow -R
:
:#============= rpcd_t ==============
:allow rpcd_t samba_etc_t:file read;
:
Comment 1 Miroslav Grepl 2012-10-23 08:30:05 EDT
We allow this in F18. Backporting.
Comment 2 Miroslav Grepl 2012-10-23 08:33:54 EDT
Added.

commit 9a79a412f68f76c4efc646b7b817d4e4d14da008
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Tue Oct 23 14:33:25 2012 +0200

    Allow nsswitch domains to read SAMBA conf files
Comment 3 Miroslav Grepl 2012-10-23 08:34:12 EDT
*** Bug 868948 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-11-13 13:31:04 EST
selinux-policy-3.10.0-96.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-96.fc16
Comment 5 Fedora Update System 2012-11-14 21:43:26 EST
Package selinux-policy-3.10.0-96.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-96.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18243/selinux-policy-3.10.0-96.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-11-19 21:58:48 EST
selinux-policy-3.10.0-96.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.