Bug 869032 - report-gtk can't open bugzilla link
report-gtk can't open bugzilla link
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
: 872811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 16:35 EDT by Jonathan Kamens
Modified: 2016-11-30 19:42 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:29:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of strace attached to report-gtk process with -f -F -v -s 1000 (7.82 MB, application/octet-stream)
2012-10-22 16:35 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2012-10-22 16:35:44 EDT
Created attachment 631723 [details]
output of strace attached to report-gtk process with -f -F -v -s 1000

This is with all F17 updates (from updates and updates-testing) applied as of today, and with a fresh, recently rebooted system.

After report-gtk finishes reporting a bug to bugzilla and reports "Status: ASSIGNED https://bugzilla.redhat.com/show_bug.cgi?id=864324", I try to click on the link to view the bug. If firefox is already running when I do that, then I get the "Firefox is already running, but is not responding." pop-up error window. If Firefox is *not* running when I click on the link, then nothing visible happens.

When I run strace on report-gtk process, then I observe that in the background, it is calling /usr/bin/gnome-open. For some reason gnome-open is unable to successfully launch firefox.

When I run exactly the same gnome-open command from the command line, it works fine. I am unable to figure out how to reproduce the issue or what is causing it.

I've attached strace output of the report-gtk process when it's trying to launch firefox. Maybe you can make some sense out of it. I can't figure it out.
Comment 1 Jakub Filak 2012-10-22 17:34:06 EDT
Thank you for filling this bug report.

It probably happens only when you report a newly detected problem. report-gtk is started from a reported dump directory. A newly reported dump directories are placed at /var/spool/abrt/ by default. After detection a dump directory is readonly for normal users but report-gtk requires write access to a reported problem thus the dump directory is moved from /var/spool/abrt to $XDG_CACHE_HOME/abrt/spool but CWD of report-gtk process remains unchanged and after the move doesn't exist. In this particular case gnome-open is unable to successfully open passed URL.
Comment 2 Jakub Filak 2012-10-24 06:22:22 EDT
Fixed in git

commit 2e82648d44891f24832d4e3e77b23eeec691b9a7
Author: Jakub Filak <jfilak@redhat.com>
Date:   Tue Oct 23 11:16:01 2012 +0200

    update CWD after stealing of a dump directory
    
    - closes rhbz#869032
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
Comment 3 Fedora Update System 2012-10-24 10:45:14 EDT
abrt-2.0.17-1.fc17,libreport-2.0.17-1.fc17,btparser-0.21-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.17-1.fc17,libreport-2.0.17-1.fc17,btparser-0.21-1.fc17
Comment 4 Fedora Update System 2012-10-24 19:55:20 EDT
Package abrt-2.0.17-1.fc17, libreport-2.0.17-1.fc17, btparser-0.21-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.17-1.fc17 libreport-2.0.17-1.fc17 btparser-0.21-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16846/abrt-2.0.17-1.fc17,libreport-2.0.17-1.fc17,btparser-0.21-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-11-01 09:55:35 EDT
abrt-2.0.18-1.fc17,libreport-2.0.18-1.fc17,btparser-0.22-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.18-1.fc17,libreport-2.0.18-1.fc17,btparser-0.22-1.fc17
Comment 6 Fedora Update System 2012-11-01 23:24:48 EDT
Package abrt-2.0.18-1.fc17, libreport-2.0.18-1.fc17, btparser-0.22-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.18-1.fc17 libreport-2.0.18-1.fc17 btparser-0.22-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17495/abrt-2.0.18-1.fc17,libreport-2.0.18-1.fc17,btparser-0.22-1.fc17
then log in and leave karma (feedback).
Comment 7 Jakub Filak 2012-11-17 05:44:28 EST
*** Bug 872811 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-12-20 11:29:24 EST
abrt-2.0.18-1.fc17, libreport-2.0.18-1.fc17, btparser-0.22-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.