Bug 869066 - [abrt]: BUG: soft lockup - CPU#0 stuck for 22s! [iscsid:1154]
[abrt]: BUG: soft lockup - CPU#0 stuck for 22s! [iscsid:1154]
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:33ed9c9c9b007b8d385ef085fc5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 18:40 EDT by Klaas Zwaan
Modified: 2012-10-24 17:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 17:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaas Zwaan 2012-10-22 18:40:29 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.4.11-1.fc16.x86_64 root=UUID=867152e9-2036-4602-8ae7-0b141306fd34 ro rd.md=0 rd.lvm=0 rd.dm=0 LANG=nl_NL.UTF-8 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0

backtrace:      Text file, 4991 bytes

backtrace:
:BUG: soft lockup - CPU#0 stuck for 22s! [iscsid:1154]
:Modules linked in: vfat fat tcp_lp fuse usb_storage be2iscsi iscsi_boot_sysfs bnx2i lockd cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp tpm_bios libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi stkwebcam videodev media vhost_net macvtap macvlan tun kvm_amd kvm uinput snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 snd_pcm joydev r852 sm_common serio_raw nand nand_ids mtd nand_ecc r592 memstick r8169 mii k8temp sp5100_tco i2c_piix4 edac_core edac_mce_amd ath5k ath asus_laptop mac80211 sparse_keymap input_polldev snd_timer snd soundcore snd_page_alloc cfg80211 rfkill shpchp sunrpc firewire_ohci sdhci_pci firewire_core sdhci ata_generic pata_acpi mmc_core crc_itu_t pata_atiixp video radeon ttm drm_kms_he
:lper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:CPU 0 
:Modules linked in: vfat fat tcp_lp fuse usb_storage be2iscsi iscsi_boot_sysfs bnx2i lockd cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp tpm_bios libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi stkwebcam videodev media vhost_net macvtap macvlan tun kvm_amd kvm uinput snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 snd_pcm joydev r852 sm_common serio_raw nand nand_ids mtd nand_ecc r592 memstick r8169 mii k8temp sp5100_tco i2c_piix4 edac_core edac_mce_amd ath5k ath asus_laptop mac80211 sparse_keymap input_polldev snd_timer snd soundcore snd_page_alloc cfg80211 rfkill shpchp sunrpc firewire_ohci sdhci_pci firewire_core sdhci ata_generic pata_acpi mmc_core crc_itu_t pata_atiixp video radeon ttm drm_kms_he
:lper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 1154, comm: iscsid Not tainted 3.4.11-1.fc16.x86_64 #1 ASUSTeK Computer Inc.  A7U                 /A7U       
:RIP: 0010:[<ffffffff813cff3d>]  [<ffffffff813cff3d>] scsi_remove_target+0xed/0x1d0
:RSP: 0018:ffff88005a407948  EFLAGS: 00000282
:RAX: 0000000000000000 RBX: 0000000000000000 RCX: ffff88005e766000
:RDX: ffff88005e766000 RSI: 0000000000000292 RDI: ffff88005af58938
:RBP: ffff88005a407988 R08: ffffffff81cd8220 R09: 0000000000000100
:R10: 0000000036b99c01 R11: 0000000000000000 R12: ffffffff81cd8220
:R13: 0000000000000100 R14: 0000000036b99c01 R15: 0000000000000000
:FS:  00007f55bcb83700(0000) GS:ffff88006fc00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 00007f094c273658 CR3: 000000005e45f000 CR4: 00000000000007f0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process iscsid (pid: 1154, threadinfo ffff88005a406000, task ffff88005a105c80)
:Stack:
: 0000000000000286 ffff88005e766000 0000000000000000 ffff88005af58938
: ffff88005af58800 ffff88005af58818 0000000000000000 0000000000000001
: ffff88005a4079b8 ffffffffa056756e ffff88005af58800 ffff88005af58938
:Call Trace:
: [<ffffffffa056756e>] __iscsi_unbind_session+0xbe/0x190 [scsi_transport_iscsi]
: [<ffffffffa0567722>] iscsi_remove_session+0xe2/0x1c0 [scsi_transport_iscsi]
: [<ffffffffa0567816>] iscsi_destroy_session+0x16/0x60 [scsi_transport_iscsi]
: [<ffffffffa0583446>] iscsi_session_teardown+0xa6/0xd0 [libiscsi]
: [<ffffffffa057b0f0>] iscsi_sw_tcp_session_destroy+0x50/0x70 [iscsi_tcp]
: [<ffffffffa0566dbe>] iscsi_if_rx+0xa9e/0xf30 [scsi_transport_iscsi]
: [<ffffffff8116e9bb>] ? kfree+0x3b/0x150
: [<ffffffff81171e55>] ? __kmalloc_node_track_caller+0x195/0x1f0
: [<ffffffff8151887c>] ? netlink_sendmsg+0x27c/0x360
: [<ffffffff815185be>] netlink_unicast+0x1ae/0x1f0
: [<ffffffff815188fe>] netlink_sendmsg+0x2fe/0x360
: [<ffffffff814d7c27>] sock_sendmsg+0x117/0x130
: [<ffffffff8112a5a7>] ? free_pages_prepare+0x87/0x130
: [<ffffffff811a0e0c>] ? mntput_no_expire+0x2c/0x120
: [<ffffffff811a0f26>] ? mntput+0x26/0x40
: [<ffffffff8118e532>] ? path_put+0x22/0x30
: [<ffffffff81191939>] ? path_lookupat+0xc9/0x730
: [<ffffffff814da45a>] ? move_addr_to_kernel+0x5a/0xa0
: [<ffffffff814e6186>] ? verify_iovec+0x56/0xd0
: [<ffffffff814d9546>] __sys_sendmsg+0x396/0x3b0
: [<ffffffff8126fa30>] ? inode_has_perm+0x30/0x40
: [<ffffffff8127102c>] ? selinux_inode_getattr+0x6c/0x70
: [<ffffffff811f1fe0>] ? sysfs_refresh_inode+0x90/0xa0
: [<ffffffff811884f8>] ? cp_new_stat+0xf8/0x110
: [<ffffffff814db399>] sys_sendmsg+0x49/0x90
: [<ffffffff81605ee9>] system_call_fastpath+0x16/0x1b
:Code: 01 48 89 c6 48 8b 7a 58 e8 81 df 22 00 48 85 db 74 d1 4c 8b 6b 28 eb 13 66 0f 1f 44 00 00 4d 8b 6d 00 4d 85 ed 0f 84 c3 00 00 00 <4c> 89 ef e8 cb 38 ff ff 85 c0 74 e7 49 81 ed 80 01 00 00 49 8b
Comment 1 Dave Jones 2012-10-23 11:39:20 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 2 Klaas Zwaan 2012-10-24 16:36:46 EDT
Now using kernel 3.6.2 and the problem seems to be solved.
I suggest to close this bug-report.
Regards.

Note You need to log in before you can comment on or make changes to this bug.