Bug 869182 - [abrt] evolution-3.6.1-1.fc18: gtk_style_context_get_valist: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.6.1-1.fc18: gtk_style_context_get_valist: Process /usr/bin...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:1f91ad3b3585cfb49f52eb56c2b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 04:35 EDT by skkd.h4k1n9
Modified: 2013-01-22 20:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 02:42:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (12.74 KB, text/plain)
2012-10-23 04:35 EDT, skkd.h4k1n9
no flags Details
File: environ (1.57 KB, text/plain)
2012-10-23 04:35 EDT, skkd.h4k1n9
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-23 04:35 EDT, skkd.h4k1n9
no flags Details
File: backtrace (82.25 KB, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: cgroup (129 bytes, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: smolt_data (2.58 KB, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: xsession_errors (150 bytes, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: maps (83.13 KB, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: dso_list (27.95 KB, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: proc_pid_status (785 bytes, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: open_fds (1.96 KB, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details
File: var_log_messages (547 bytes, text/plain)
2012-10-23 04:36 EDT, skkd.h4k1n9
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 687360 None None None Never

  None (edit)
Description skkd.h4k1n9 2012-10-23 04:35:51 EDT
Version-Release number of selected component:
evolution-3.6.1-1.fc18

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.16
backtrace_rating: 4
cmdline:        evolution -c calendar
crash_function: gtk_style_context_get_valist
kernel:         3.6.2-4.fc17.i686

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 gtk_style_context_get_valist at gtkstylecontext.c:1428
: #1 gtk_style_context_get at gtkstylecontext.c:1463
: #2 set_color_from_context at deprecated/gtkstyle.c:651
: #3 set_color at deprecated/gtkstyle.c:709
: #4 gtk_style_update_from_context at deprecated/gtkstyle.c:745
: #10 gtk_style_context_do_invalidate at gtkstylecontext.c:3000
: #11 _gtk_style_context_queue_invalidate at gtkstylecontext.c:3226
: #12 _gtk_style_context_set_widget at gtkstylecontext.c:1128
: #13 gtk_widget_finalize at gtkwidget.c:10338
: #14 webkit_web_view_finalize at /lib/libwebkitgtk-3.0.so.0
Comment 1 skkd.h4k1n9 2012-10-23 04:35:55 EDT
Created attachment 631944 [details]
File: core_backtrace
Comment 2 skkd.h4k1n9 2012-10-23 04:35:57 EDT
Created attachment 631945 [details]
File: environ
Comment 3 skkd.h4k1n9 2012-10-23 04:35:59 EDT
Created attachment 631946 [details]
File: limits
Comment 4 skkd.h4k1n9 2012-10-23 04:36:02 EDT
Created attachment 631947 [details]
File: backtrace
Comment 5 skkd.h4k1n9 2012-10-23 04:36:05 EDT
Created attachment 631948 [details]
File: cgroup
Comment 6 skkd.h4k1n9 2012-10-23 04:36:07 EDT
Created attachment 631949 [details]
File: smolt_data
Comment 7 skkd.h4k1n9 2012-10-23 04:36:09 EDT
Created attachment 631950 [details]
File: xsession_errors
Comment 8 skkd.h4k1n9 2012-10-23 04:36:13 EDT
Created attachment 631951 [details]
File: maps
Comment 9 skkd.h4k1n9 2012-10-23 04:36:17 EDT
Created attachment 631952 [details]
File: dso_list
Comment 10 skkd.h4k1n9 2012-10-23 04:36:19 EDT
Created attachment 631953 [details]
File: proc_pid_status
Comment 11 skkd.h4k1n9 2012-10-23 04:36:22 EDT
Created attachment 631954 [details]
File: open_fds
Comment 12 skkd.h4k1n9 2012-10-23 04:36:24 EDT
Created attachment 631955 [details]
File: var_log_messages
Comment 13 Milan Crha 2012-10-23 05:54:14 EDT
Thanks for a bug report. I see from the backtrace that you were closing evolution, but otherwise it looks like some memory corruption bug. Do you see it regularly, after certain set of steps, or it's just an occasional crash?
Comment 14 Milan Crha 2012-11-29 02:42:57 EST
Thanks for a bug report. There is filled a similar upstream bug [1], thus I'm moving this there. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=687360
Comment 15 NM 2013-01-22 20:25:15 EST
I do observe it too. Pretty regularly. Thanks.

Note You need to log in before you can comment on or make changes to this bug.