Bug 869369 - KeyError: '/dev/vda'
KeyError: '/dev/vda'
Status: CLOSED DUPLICATE of bug 866680
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9bbbe35b2388885cfd81c31067e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 13:25 EDT by Reartes Guillermo
Modified: 2013-08-07 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 19:42:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (241.92 KB, text/plain)
2012-10-23 13:25 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-23 13:25 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-23 13:25 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: storage.log (85.65 KB, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (9.11 KB, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: syslog (72.90 KB, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details
File: program.log (26.60 KB, text/plain)
2012-10-23 13:26 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-23 13:25:45 EDT
Description of problem:
i selected multiple disks, and went to manual partitioning. i just selected one partition.

Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 871, in allocatePartitions
:    disklabel = disklabels[_disk.path]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 763, in doPartitioning
:    allocatePartitions(storage, disks, partitions, free)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1932, in allocatePartitions
:    doPartitioning(self)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1920, in setContainerMembers
:    self.allocatePartitions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2056, in newDevice
:    members=members)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1116, in _save_right_side
:    raid_level=raid_level)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1795, in on_selector_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 192, in _onSelectorClicked
:    cb(selector)
:KeyError: '/dev/vda'
Comment 1 Reartes Guillermo 2012-10-23 13:25:55 EDT
Created attachment 632229 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-23 13:25:57 EDT
Created attachment 632230 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-23 13:25:59 EDT
Created attachment 632231 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-23 13:26:02 EDT
Created attachment 632232 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-23 13:26:05 EDT
Created attachment 632233 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-23 13:26:08 EDT
Created attachment 632234 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-23 13:26:10 EDT
Created attachment 632235 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-23 13:26:12 EDT
Created attachment 632236 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-23 13:26:16 EDT
Created attachment 632237 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-23 13:26:18 EDT
Created attachment 632238 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-23 13:26:21 EDT
Created attachment 632239 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-23 13:26:23 EDT
Created attachment 632240 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-23 13:26:25 EDT
Created attachment 632241 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-23 13:26:28 EDT
Created attachment 632242 [details]
File: program.log
Comment 15 Reartes Guillermo 2012-10-23 13:33:17 EDT
Steps to reproduce:

0. Enter STORAGE: INSTALLATION DESTINATION
1. Select the first 4 disks, do MANUAL PARTITIONING
2. Expand the 'unknown' tree. 
3. There will be two entries: a 1mb ext4 and a 16gb btrfs.
4. click the btrfs one, then click back the 1mb ext4.

The error happens upon clicking back the 1mb ext4 partition.
Comment 16 Brian Lane 2013-08-07 19:42:09 EDT

*** This bug has been marked as a duplicate of bug 866680 ***

Note You need to log in before you can comment on or make changes to this bug.