Bug 869388 - F18b TC anaconda manual partitioning multiple selection with the keyboard
F18b TC anaconda manual partitioning multiple selection with the keyboard
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 14:34 EDT by Reartes Guillermo
Modified: 2012-11-23 01:01 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.21-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 01:01:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of multi-select (83.10 KB, image/png)
2012-10-23 14:34 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-23 14:34:07 EDT
Created attachment 632297 [details]
screenshot of multi-select

Description of problem:

With the keyboard, i can select multiple partitions. I could not figure out
the intended purpose of it. It seems to be not possible to operate with more than one partition selected. So i am not sure if it is a bug or if something is expected from such selections.

Please clarify.

Version-Release number of selected component (if applicable):
F18b TC6

How reproducible:
always

Steps to Reproduce:
1. go to manual partitioning
2. select any partition and use the UP/DOWN keys then try to operate
  
Actual results:
unclear (but no crash or error)

Expected results:
unknown, either not being able to multi-select or multi-select should work.

Additional info:
Comment 1 Vratislav Podzimek 2012-10-24 06:27:17 EDT
Problem here is, that the selector that has been clicked stays focused when UP/DOWN keys are used to move to another selector. Selectors focused by UP/DOWN keys "unfocus" correctly.
Comment 2 Vratislav Podzimek 2012-10-24 06:38:19 EDT
focus-out-event signal is not emitted by the selector when it was focused with mouse and then UP/DOWN key is used to move to another selector (widget). Gtk documentation says:
> The ::focus-out-event signal will be emitted when the keyboard focus leaves
> the widget's window.
Comment 3 Vratislav Podzimek 2012-10-24 06:43:59 EDT
(In reply to comment #2)
> focus-out-event signal is not emitted by the selector when it was focused
> with mouse and then UP/DOWN key is used to move to another selector
> (widget). Gtk documentation says:
> > The ::focus-out-event signal will be emitted when the keyboard focus leaves
> > the widget's window.
There is probably a different problem -- only the background is not toggled.
Comment 4 Adam Williamson 2012-11-23 01:01:05 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(tested with Beta RC1, looks to work fine.)

Note You need to log in before you can comment on or make changes to this bug.