Bug 869503 - Failed to passthrough smartcard to guest
Failed to passthrough smartcard to guest
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 02:02 EDT by hongming
Modified: 2013-12-01 21:27 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 23:39:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smardcard debug log (239.98 KB, text/x-log)
2012-10-24 02:02 EDT, hongming
no flags Details

  None (edit)
Description hongming 2012-10-24 02:02:16 EDT
Created attachment 632551 [details]
smardcard debug log

Description of problem:
Guest can't identify  smardcard after passthrough it to guest. 

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-15.el6.x86_64
python-virtinst-0.600.0-9.el6
spice-gtk-0.14-3.el6.x86_64
libvirt-0.10.2-4.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Create a VM with smartcard device. And it should be passthrough mode. 
2.On both of your host and guest. 
 #yum groupinstall "smart card support"
 #yum remove '*openct*'
 #Service pcscd start
3.Get root CA certificate and install it in guest
4.#virt-viewer guest --spice-smartcard
5.In guest , Applications -> System Tools -> Smard Card Manager 
No card present 
  
Actual results:
Guest can't identify smardcard after passthrough it to guest.

Expected results:
It works fine

Additional info:
Comment 2 hongming 2012-10-24 02:20:40 EDT
about spice version. please refer to the following.
# rpm -qa|grep spice
spice-glib-0.14-4.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-server-0.12.0-1.el6.x86_64
spice-gtk-python-0.14-4.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-gtk-0.14-4.el6.x86_64
Comment 4 hongming 2012-10-24 23:39:01 EDT
Sorry, I re-test the case. It is caused by one wrong step. So it is NOT A BUG.
Comment 5 Dave Allan 2012-10-25 10:33:21 EDT
Ok, thanks for rechecking.

Note You need to log in before you can comment on or make changes to this bug.