Bug 869541 - webadmin: we do not show current connected devices when creating a new domain in 3.0 DC on upgraded 3.1 rhevm
webadmin: we do not show current connected devices when creating a new domain...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.5
Assigned To: Ayal Baron
Pavel Stehlik
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 04:20 EDT by Dafna Ron
Modified: 2016-02-10 13:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 10:56:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.40 MB, application/x-gzip)
2012-10-24 04:20 EDT, Dafna Ron
no flags Details
logs and screen shot (481.25 KB, application/x-gzip)
2012-10-28 06:31 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-10-24 04:20:23 EDT
Created attachment 632619 [details]
logs

Description of problem:

I have a setup upgraded to 3.1 rhevm from 3.0 rhevm
when I create a new domain and select a DC which is 3.0 (either existed before the upgrade or a new one created in the setup) I cannot see the current connection on the host. 

Version-Release number of selected component (if applicable):

si21.1

How reproducible:

100%

Steps to Reproduce:
1. upgrade a 3.0 to 3.1
2. go to storage tab -> new domain -> select 3.0 DC
3. create a new 3.0 with a 1 domain -> storage tab -> new domain -> select the DC
4. create a new 3.1 DC with 1 domain -> storage tab -> new domain -> select the DC
  
Actual results:

if the DC is 3.0 (either existing DC or a new created one) we would not see any of the existing connections although we can see that engine sent getDeviceList and that the vdsm sent results. 
if the DC is 3.1 we can see the connected devices. 

I checked on rhevm 3.0 and you can see the devices  so this is because of the upgrade. 

Expected results:

we should see the results 

Additional info: all logs



this is the iscsiadm output:

existing 3.0 DC: 

[root@gold-vdsd ~]# iscsiadm -m session
tcp: [10] 10.35.64.10:3260,1 Dafna-upgrade-01
tcp: [11] 10.35.64.10:3260,1 Dafna-upgrade-02
tcp: [12] 10.35.64.10:3260,1 Dafna-Upgrade-03
tcp: [13] 10.35.64.10:3260,1 Dafna-Upgrade-04


new 3.0 DC: 

[root@gold-vdsc ~]# iscsiadm -m session
tcp: [15] 10.35.64.10:3260,1 Dafna-tmp-02
[root@gold-vdsc ~]# 

new 3.1 DC:

[root@nott-vds2 ~]# iscsiadm -m session
tcp: [12] 10.35.64.10:3260,1 Dafna-tmp-01
[root@nott-vds2 ~]# 


if you look at the screen shots:

iSCSI = 3.0 existing 
iSCSI2 = 3.1 new DC
iSCSI3 = 3.0 new DC
Comment 2 Ayal Baron 2012-10-25 16:53:37 EDT
All the LUNs returned from vdsm in getDeviceList (in all 3 logs) are part of existing VGs.
In 3.0 these LUNs were filtered out hence nothing is displayed.
In 3.1 we have the option to display these devices as 'used'.

Please provide a log (and screenshot) of where such devices were displayed in 3.0 version.
Comment 3 Dafna Ron 2012-10-28 06:30:38 EDT
these connected luns exist in 3.0 and always have been. 

at your request, 3.0 logs and screen shot from rhevm-3 which is a 3.0 setup
Comment 4 Dafna Ron 2012-10-28 06:31:05 EDT
Created attachment 634476 [details]
logs and screen shot
Comment 5 Ayal Baron 2012-10-28 07:45:40 EDT
but what LUNs are displayed when you expand the target in 3.0?
Comment 6 Dafna Ron 2012-10-28 08:03:26 EDT
all the luns which are part of existing domains in pool.
Comment 7 Ayal Baron 2012-11-07 10:56:58 EST
After reviewing with Dafna on a 3.0 setup this is exactly the same behaviour in all 3.0 DCs.  The reason is that the view is targets->luns, since we do not support 'grayed out' luns in 3.0 we do not display anything.
In 3.1, even when all LUNs are 'used' (as is the case here) we show these LUNs in GUI as grayed out which is why the targets are also visible.

Note You need to log in before you can comment on or make changes to this bug.