Bug 869552 - RPM installation - prerequisites packages
RPM installation - prerequisites packages
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 04:46 EDT by Ondrej Chaloupka
Modified: 2012-11-08 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:10:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2012-10-24 04:46:05 EDT
The section about prerequisites (http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html-single/Installation_Guide/index.html#sec-Prerequisites-Linux) contains strange packages.
This fact was mentioned in mail of pjanouse last week but I can't see whether it was solved or not. So I'm creating this bz.

Are the mentioned packages really needed to be installed?
Could Weinan clarify what is needed and what is not?


A note: The section about prerequisites for RPM installation should be rework maybe and the prerequisites should be moved directly to chapter 2.3. But it depends on point of view.
Comment 1 Weinan Li 2012-10-24 04:55:20 EDT
"krb5-workstation
mod_auth_kerb
elinks (required for the apachectl functionality)
"

These are deprecated. We don't need them :-)
Comment 2 Ondrej Chaloupka 2012-10-24 05:05:55 EDT
Hi, 

thank you. Just sorry for one more question but there is this sentence as well:
"One of the following packages must be installed as a prerequisite: apr-devel or apr-util-devel"

Do we need to install one of them?
Comment 3 Weinan Li 2012-10-24 05:41:47 EDT
We don't need to install these 'devel' packages to use EWS2. But I think in ZIP distributions we include these header files. So maybe for RPM installation we could ask customer to install these, it's harmless, and it's part of the EWS2. So let's keep it as-is.
Comment 4 Radim Hatlapatka 2012-10-24 07:36:23 EDT
These packages are required at least for ZIP distributions
Comment 5 Ondrej Chaloupka 2012-10-24 10:29:52 EDT
Ok, for ZIP distribution on RHEL the prerequisites are valid. The user has to install all packages.

For RPM installation, as Weinan mentioned, the packages are deprecated.

So it would be nice to clarify in documentation what is and what isn't needed for which type of installation.

This bz is related to: https://bugzilla.redhat.com/show_bug.cgi?id=864391
Comment 6 Misha H. Ali 2012-10-24 20:00:09 EDT
Altered structure to create new sections, one for the ZIP install prerequisites, one for the RPM install prerequisites. The ZIP installation, as outlined in the comments, remains exactly the same. The RPM installation is cloned and modified.

According to comment#3, perhaps removing this requirement is best, as they are not required? I have removed them but can add them back if there is a need for them.
Comment 8 Ondrej Chaloupka 2012-10-25 04:59:52 EDT
Returning to assigned.

Section 
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html-single/Installation_Guide/index.html#proc-Installing_Required_Packages-Linux
still refers to the packages from prerequisites what, I suppose, is wrong. 

Then there is mistification of user in the guide because you will find link 
refer to Procedure 2.2, “Installing Required Packages”
in section
http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html-single/Installation_Guide/index.html#sec-Installing_EWS_from_RPM_Packages

and this link points to #proc-Installing_Required_Packages-Linux

probably removing (or moving that section to zip info) would be solution. Then please remove old links amongst sections.
Comment 9 Ondrej Chaloupka 2012-10-25 05:28:18 EDT
One more change:
RPM has prerequisite package and it's package "elinks".
Please add this information to prerequisites section of RPM.
Thank you
Comment 10 Misha H. Ali 2012-10-25 05:52:41 EDT
Ondrej, regarding elinks, please see the below bug, comment#1:

https://bugzilla.redhat.com/show_bug.cgi?id=869552

This is the reason it was removed for RPM.

-----

Can you clarify this feedback please, I'm not sure I have understood what you mean:

> Section 
> http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html-single/Installation_Guide/index.html#proc-Installing_Required_Packages-Linux
> still refers to the packages from prerequisites what, I suppose, is wrong. 

This procedure is linked to only in the ZIP install prerequisites, and they should be correct for them. Did you mean something else?

-----

> Then there is mistification of user in the guide because you will find link 
> refer to Procedure 2.2, “Installing Required Packages”
> in section
> http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html-single/Installation_Guide/index.html#sec-Installing_EWS_from_RPM_Packages

Good catch, this is now fixed so that it just tells users to go to the linked RPM prereq section and to ensure all prerequisites are met.
Comment 11 Weinan Li 2012-10-25 05:55:18 EDT
Hi Misha, sorry for my incorrect information, elinks is needed.

mod_auth_kerb and krb5-workstation are moved out of support scope. I should read your comment more carefully. Sorry for the inconvenience.
Comment 12 Misha H. Ali 2012-10-25 06:07:25 EDT
Oh, OK. Thanks for the clarification, Wei Nan. I'll add it back and set this bug to ON_QA.
Comment 13 Misha H. Ali 2012-10-25 06:17:07 EDT
Sorry Ondrej, the docs stage appears to be down (or at least not updating for the last three hours). The changes can be verified here (link is for the last elinks change specifically):

http://file.bne.redhat.com/~mhusnain/Installation_Guide/html-single/#sec-Prerequisites-Linux-RPM
Comment 14 Ondrej Chaloupka 2012-10-26 03:20:27 EDT
OK, it seems fine. Just please add the changes to docs stage when it will be possible.
Thank you
Comment 15 Misha H. Ali 2012-11-08 17:10:38 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.