Bug 869577 - Unable to install some third part packages
Unable to install some third part packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
18
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 06:13 EDT by carasin
Modified: 2012-10-24 09:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 08:30:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carasin 2012-10-24 06:13:43 EDT
Description of problem:

Sometimes I have to use BricsCAD. But now it's impossible to install it correctly in Fedora 18. YUM tells this:
> Transaction Check Error:
>  file / from install of bricscadv12-12.1.23-1.i386 conflicts with file from package filesystem-3.1-2.fc18.i686
>  file /usr/bin from install of bricscadv12-12.1.23-1.i386 conflicts with file from package filesystem-3.1-2.fc18.i686
RPM says the same.
___________________________________

Version-Release number of selected component (if applicable):

filesystem-3.1-2.fc18.i686
yum-3.4.3-45.fc18.noarch
rpm-4.10.1-3.fc18.i686
___________________________________

How reproducible:

Always
___________________________________

Steps to Reproduce:

1. Download BricsCAD RPM package: http://www.bricsys.com/common/download.jsp
2. sudo yum localinstall ./Bricscad*.rpm --nogpgcheck
  
Actual results:

YUM/RPM doesn't install the BricsCAD package
___________________________________

Expected results:

YUM/RPM installs the BricsCAD package
___________________________________

Additional info:

In F16 and F17 this package was installable.
Comment 1 carasin 2012-10-24 06:21:12 EDT
VirtualBox from Oracle's repository for F17 is not installable too (there is no F18 repo). An error is the same.
Comment 2 Ondrej Vasik 2012-10-24 08:30:48 EDT
Thanks for report, this is probably an error in bricscadv12 packaging. bricscadv12-12.1.23-1.i386 package should not own the basic directories. I assume they incorrectly change the attributes of the directories - as the directory permissions were tightened because of the lowering capabilities - https://bugzilla.redhat.com/show_bug.cgi?id=517575 . If you think there is something wrong with filesystem package, please be more specific. What you have reported is not a bug in filesystem package, closing.

As workaround you may use --replacefiles rpm option, however - as I said, permissions on the system directories are intentional.
Comment 3 carasin 2012-10-24 09:19:08 EDT
Thanks for explaination.

Note You need to log in before you can comment on or make changes to this bug.