Bug 869629 - Request to add a patch to the mvsas driver to fix a kernel oops
Request to add a patch to the mvsas driver to fix a kernel oops
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 871885 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 08:45 EDT by Inworks GmbH
Modified: 2012-12-17 21:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 03:26:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the mvsas driver. (679 bytes, patch)
2012-10-24 08:45 EDT, Inworks GmbH
no flags Details | Diff

  None (edit)
Description Inworks GmbH 2012-10-24 08:45:02 EDT
Created attachment 632760 [details]
Patch to the mvsas driver.

We experience oopses similar to the one described in bug #848798.
The main difference is that we use a Marvell 88SE9480 controller.

The standard Fedora kernel 3.6.2-4 contains a buggy version of the mvsas driver.
Accessing a harddisk with unreadable sectors leads to a kernel oops and a hanging machine.

We've found a fix to the issue in the git repository of the kernel at http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=95ab000388974d8ffef8257306b4be6e8778b768

Currently we run a custom-build kernel with the attached patch applied.
It would be nice, however, if you could include the patch in the regular Fedora kernel so we can return to the stock kernel.
Comment 1 Josh Boyer 2012-10-24 09:22:21 EDT
I'll try to get that in later today.
Comment 2 Erasmo Acosta 2012-10-31 12:25:20 EDT
Hello,

I just opened Bug 871885. Could you please take a look and tell me if this is something your driver will resolve?

Thanks,
Erasmo.
Comment 3 Josh Boyer 2012-11-26 13:39:28 EST
*** Bug 871885 has been marked as a duplicate of this bug. ***
Comment 4 Josh Boyer 2012-11-26 13:43:52 EST
Embarrassingly, this just went in today.  My apologies for the significant delay.
Comment 5 Fedora Update System 2012-11-28 07:58:34 EST
kernel-3.6.8-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.8-2.fc16
Comment 6 Fedora Update System 2012-11-28 08:28:43 EST
kernel-3.6.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.8-2.fc17
Comment 7 Fedora Update System 2012-11-28 22:57:22 EST
Package kernel-3.6.8-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.8-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19337/kernel-3.6.8-2.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-01 03:26:36 EST
kernel-3.6.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-12-04 16:14:03 EST
kernel-3.6.9-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.9-4.fc18
Comment 10 Fedora Update System 2012-12-04 16:18:28 EST
kernel-3.6.9-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.9-2.fc16
Comment 11 Fedora Update System 2012-12-06 23:25:53 EST
kernel-3.6.9-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-12-11 15:18:25 EST
kernel-3.6.10-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.10-2.fc16
Comment 13 Fedora Update System 2012-12-17 21:34:29 EST
kernel-3.6.10-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.