Bug 869631 - [RHEV-H 6.4]RHEV-H only use "Other Device" to create HOSTVG.
[RHEV-H 6.4]RHEV-H only use "Other Device" to create HOSTVG.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 08:47 EDT by haiyang,dong
Modified: 2013-02-28 11:42 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
On a Red Hat Enterprise Virtualization Hypervisor TUI installation, selecting a target device to boot from in the "Other Device" category does not uncheck the "Other Device" category. This is intended behavior. For clarification purposes, this fix will uncheck "Other Device" and will only put a checkmark on the target device chosen.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:42:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-10-24 08:47:17 EDT
Description of problem:
There are two disks "/dev/sda" and "/dev/sdb",Select device /dev/sda to use for booting RHEV-H, then enter into "Select the disk(s) to use for installation of RHEV Hypervisor" Page
Select device /dev/sda, and select "Other Device", then click "Continue" Button to configure "Other Device" into "/dev/sdb",

But rhev-h only use Other Device(/dev/sdb) to create HOSTVG
cat /etc/default/ovirt
-----------------------
....
OVIRT_INIT="/dev/sda,/dev/sdb,"
....

[root@localhost admin]# pvs
  PV                     VG     Fmt  Attr PSize  PFree
  /dev/sdb1             HostVG lvm2 a--  14.91g    0


Also tried another scenarios:
Select device /dev/sda to use for booting RHEV-H, then enter into "Select the disk(s) to use for installation of RHEV Hypervisor" Page
Select device /dev/sda and /dev/sdb then click "Continue" Button ,

Then drop to shell, check the /etc/default/ovirt
----------------------
....
OVIRT_INIT="/dev/sda,/dev/sda,/dev/sdb,"
....

Using this scenarios, RHEV-H can use "/dev/sda" and "/dev/sdb" to create HOSTVG

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible:
100% 
  
Steps to Reproduce:
1.Insert the installation media(CD-ROM/USB), and start the system.
2.clean install rhev-h via TUI
3.Select device /dev/sda to use for booting RHEV-H
4.Enter into "Select the disk(s) to use for installation of RHEV Hypervisor" Page
Select device /dev/sda, and select "Other Device", then click "Continue" Button to configure "Other Device" into "/dev/sdb"

Actual result:
After Step 4, RHEV-H only use "Other Device" to create HOSTVG.

Expect result:
After Step 4, RHEV-H should use these two disks /dev/sda, /dev/sdb to create HOSTVG.
Comment 3 haiyang,dong 2012-12-18 02:25:39 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.el6 
ovirt-node-2.5.0-11.el6

Tested as follows:
When checking Other Device, all "/dev/XXXXX"  devices are unchecked. When checking any "/dev/XXXX" device "other device" will uncheck

Also used the "Other Device" to Create HOSTVG on /dev/sda and /dev/sda,/dev/sdb
successfully.

so this bug has been fixed, change the status into "VERIFIED"
Comment 5 errata-xmlrpc 2013-02-28 11:42:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.