Bug 869636 - problematic DUID configuration
problematic DUID configuration
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
5.7
x86_64 Linux
low Severity unspecified
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 08:57 EDT by elias
Modified: 2013-11-13 09:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 10:45:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description elias 2012-10-24 08:57:23 EDT
Description of problem:
I have a client with MAC address 52:54:00:F8:2D:0C. Choice of DUID for this adapter is
00:01:00:01:18:12:27:1f:48:aa:c1:b1:62:2b
(from /var/lib/dhcpv6/client6.leases204339200)
^00:01 indicates that this should be a DUID-LLT, but I don't see the MAC address anywhere there. I also don't see any MAC address on that system inside of this DUID.

Moreover, DUID is stored in binary form and this is very inconvenient when you need to copy this data to config file of DHCPv6 server.

There also seems to be no option for selecting DUID-LL type instead DUID-LLT (or something what wants to look like DUID-LLT).

Version-Release number of selected component (if applicable):
Name       : dhcpv6
Arch       : x86_64
Version    : 1.0.10
Release    : 20.el5


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
DUID type cannot be changed and is not a proper LLT DUID.

Expected results:
DUID type should be configurable and real DUIDs should match the specification.


Additional info:
Comment 1 Jiri Popelka 2012-10-24 11:28:18 EDT
(In reply to comment #0)
> I have a client with MAC address 52:54:00:F8:2D:0C. Choice of DUID for this
> adapter is
> 00:01:00:01:18:12:27:1f:48:aa:c1:b1:62:2b
> (from /var/lib/dhcpv6/client6.leases204339200)
> ^00:01 indicates that this should be a DUID-LLT, but I don't see the MAC
> address anywhere there.

Yes, this seems to be a bug, the last octets should contain the link layer address. However probably not a serious one, because RFC 3315 says:
"Clients and servers MUST treat DUIDs as opaque values and MUST only
compare DUIDs for equality. Clients and servers MUST NOT in any
other way interpret DUIDs."

> Moreover, DUID is stored in binary form and this is very inconvenient when
> you need to copy this data to config file of DHCPv6 server.

Strange, in my case the /var/lib/dhcpv6/client6.leases<IAID> is ASCII text file.
 
> There also seems to be no option for selecting DUID-LL type instead DUID-LLT
> (or something what wants to look like DUID-LLT).

I have no idea whether there's a way to change the DUID type, sorry.
Comment 2 Jiri Popelka 2013-03-05 10:45:27 EST
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production phase 2 [1] release of RHEL-5.
I'm closing this bugzilla as WONTFIX because since phase 2 we'll be addressing only security or critical issues.

[1] https://access.redhat.com/support/policy/updates/errata/
Comment 3 Jiri Popelka 2013-11-13 09:05:39 EST
(In reply to elias from comment #0)
> ^00:01 indicates that this should be a DUID-LLT, but I don't see the MAC
> address anywhere there. I also don't see any MAC address on that system
> inside of this DUID.

If you by any chance still need it, I back-ported (because of bug #1028314) a patch that should fix this.
Unofficial builds are here
http://jpopelka.fedorapeople.org/dhcpv6-DUID-MAC/

Note You need to log in before you can comment on or make changes to this bug.