Bug 869757 - repo sync can run on repository that doesn't exist.
repo sync can run on repository that doesn't exist.
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 41
Assigned To: Jay Dobies
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 14:25 EDT by Preethi Thomas
Modified: 2013-09-09 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:07:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-10-24 14:25:00 EDT
Description of problem:
repo sync can run on repository that doesn't exist.

Version-Release number of selected component (if applicable):

[root@pulp-master ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.333-1.fc17.noarch
[root@pulp-master ~]# 

How reproducible:


Steps to Reproduce:

[root@pulp-master ~]# pulp-admin repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

Id:                 scientific
Display Name:       scientific
Description:        None
Content Unit Count: 487

Id:                 zoo
Display Name:       zoo
Description:        None
Content Unit Count: 39


[root@pulp-master ~]# 
[root@pulp-master ~]# 
[root@pulp-master ~]# pulp-admin rpm repo sync run --repo-id foo
+----------------------------------------------------------------------+
                     Synchronizing Repository [foo]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Publishing packages...
[==================================================] 100%
Packages: 0/0 items
... completed

Publishing distributions...
[==================================================] 100%
Distributions: 0/0 items
... completed

Generating metadata
[-]
... completed

Publishing repository over HTTP
[-]
... skipped

Publishing repository over HTTPS
[-]
... completed

Downloading metadata...
[-]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       32/32 items
Delta RPMs: 0/0 items
Tree Files: 0/0 items
Files:      0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

[root@pulp-master ~]# 

1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Dobies 2012-10-31 15:47:40 EDT
commit 3c0cd3b61dbb60e7f437c06886a957cd23de577c


$ pulp-admin rpm repo sync run --repo-id fake
+----------------------------------------------------------------------+
                    Synchronizing Repository [fake]
+----------------------------------------------------------------------+

The following resource(s) could not be found:

  fake (repo_id)
Comment 2 Preethi Thomas 2012-11-07 20:14:18 EST
looking at the date of commit and also the testing ,it looks like its not in the 335 build. moving it back to modified.
Comment 3 Jeff Ortel 2012-11-12 17:33:41 EST
build: 2.0.6-0.2.beta
Comment 4 Preethi Thomas 2012-11-26 21:24:12 EST
verified

[root@preethi-el6-pulp ~]# rpm -q pulp-server
pulp-server-2.0.6-0.9.beta.noarch
[root@preethi-el6-pulp ~]# 
[root@preethi-el6-pulp ~]# 
[root@preethi-el6-pulp ~]# pulp-admin rpm repo list
+----------------------------------------------------------------------+
                              Repositories
+----------------------------------------------------------------------+

Id:                 rhel5
Display Name:       rhel5
Description:        None
Content Unit Count: 3366

Id:                 testerrata
Display Name:       testerrata
Description:        None
Content Unit Count: 61

Id:                 testerrata2
Display Name:       testerrata2
Description:        None
Content Unit Count: 61

Id:                 scientific
Display Name:       scientific
Description:        None
Content Unit Count: 562


[root@preethi-el6-pulp ~]# pulp-admin rpm repo sync run --repo-id foo
+----------------------------------------------------------------------+
                     Synchronizing Repository [foo]
+----------------------------------------------------------------------+

The following resource(s) could not be found:

  foo (repo_id)


[root@preethi-el6-pulp ~]#
Comment 5 Preethi Thomas 2013-01-09 12:07:24 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.