Bug 869984 - [RHEV-H 6.4]the netconsole didn't work although it's service still was running after reboot rhev-h
[RHEV-H 6.4]the netconsole didn't work although it's service still was runnin...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 05:49 EDT by haiyang,dong
Modified: 2013-02-28 11:43 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously the netconsole service was configured and started correctly, but it also stopped immediately upon boot because of a mandatory network restart. Now the service is restarted after the network is up, so netconsole is correctly enabled.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:43:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-10-25 05:49:28 EDT
Description of problem:
Although the netconsole service was loaded automatically after reboot rhev-h,but it didn't work
user need to restart it it manually by drop to shell or configure it again via TUI to make it work

[root@localhost admin]# runlevel 
N 3
[root@localhost admin]# chkconfig |grep netconsole
netconsole             0:off        1:off        2:off        3:on        4:off        5:on        6:off

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121015.1.el6

How reproducible: 
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.4-20121015.1.el6
2. Configure network for rhev-h
3. Configure netconsole in TUI.
4. Press F2 drop to shell, check the netconsole service
[root@localhost admin]# service netconsole status
netconsole module loaded
[root@localhost admin]# echo 7 >/proc/sys/kernel/printk
[root@localhost admin]# echo “test ” >/dev/kmsg
In the receiver console can receive "test"
[root@localhost redhat]# nc -l -u 6666
“test ”

5. Reboot the system, check the netconsole service status and function after reboot
[root@localhost admin]# service netconsole status
netconsole module loaded
[root@localhost admin]# echo 7 >/proc/sys/kernel/printk
[root@localhost admin]# echo “test ” >/dev/kmsg
[root@localhost admin]# service netconsole restart
Disabling netconsole                                       [  OK  ]
Initializing netconsole                                    [  OK  ]
[root@localhost admin]# echo “test ” >/dev/kmsg

In the receiver console can receive "test"
[root@localhost redhat]# nc -l -u 6666
netconsole: local port 6666
netconsole: local IP 10.66.10.221
netconsole: interface breth0
netconsole: remote port 6666
netconsole: remote IP 10.66.11.196
netconsole: remote ethernet address 44:37:e6:5d:f4:ab
console [netcon0] enabled
netconsole: network logging started
“test ”

so you can see that before restart it it manually, no "test" can be receive in receiver console,
but after restart it it manually,it receive "test" info.


Actual results:
Although the netconsole service was loaded automatically after reboot rhev-h,but it didn't work

Expected results:
After reboot rhev-h, the netconsole service should be loaded automatically and its' function can work

Additional info:
--------
Comment 4 Fabian Deutsch 2012-10-26 05:08:51 EDT
http://gerrit.ovirt.org/#/c/8848/

ovirt-early was to early. There is a network restart during the boot (to restart the network when the bind mounted ifcfg-* are available). So this works when it is run in ovirt-post (after the network restart).
Network restarts "stop" netconsole.

Tested as follows:
1. Install rhevh
2. Configure Network
3. Configure Netconsole
4. Reboot
5. Login an drop to shell
6. echo 7 >/proc/sys/kernel/printk
8. echo foo_bar_baz > /dev/kmsg

foo_bar_baz appears on receiver side.
Comment 6 haiyang,dong 2012-12-17 01:34:26 EST
Test version:
rhev-hypervisor6-6.4-20121212.1.el6 
ovirt-node-2.5.0-11.el6

Tested as follows:
1. Install rhevh
2. Configure Network
3. Configure Netconsole
4. Press F2 to drop to shell
5. echo 7 >/proc/sys/kernel/printk
6. echo redhat > /dev/kmsg,
redhat appears on receiver side.
7. Reboot
8. Login an drop to shell
9. echo 7 >/proc/sys/kernel/printk
10.echo redhat > /dev/kmsg,
redhat appears on receiver side.

so this bug has been fixed, change the status into "VERIFIED"
Comment 8 errata-xmlrpc 2013-02-28 11:43:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.