Bug 870115 - LVM2: Presence of sparse volume causes boot to hang a long time
LVM2: Presence of sparse volume causes boot to hang a long time
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 11:07 EDT by Robert Peterson
Modified: 2012-11-05 03:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-05 03:41:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Peterson 2012-10-25 11:07:58 EDT
Description of problem:
If there are sparse logical volumes present, rebooting takes
an extremely long time. On one of my machines, there were three
sparse volumes and it took over 18 hours to reboot. I removed
two of them and the time went down considerably, but still took
a half hour to boot. The hang seems to occur while trying to
activate the volume with the sparse volume.

I have two volume groups, "sasdrives" and "intec". With the
sparse volume on "intec" alone, it seems to hang after this
console message:

Setting up Logical Volume Management:
  2 logical volume(s) in volume group "sasdrives" now active

But before this message:
  2 logical volume(s) in volume group "intec" now active

If I remove all sparse volumes, the bootup is fast.

Version-Release number of selected component (if applicable):
lvm2-2.02.95-10.el6.x86_64
lvm2-cluster-2.02.95-10.el6.x86_64
Linux intec1 2.6.32-335.el6.x86_64 #1 SMP Fri Oct 19 02:32:06 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Always

Steps to Reproduce:
1. lvcreate --virtualsize 2T -L230G -n sparse /dev/intec
2. /sbin/reboot
  
Actual results:
Setting up Logical Volume Management:
  2 logical volume(s) in volume group "sasdrives" now active
(Pause for 30 minutes to 18 hours)
  2 logical volume(s) in volume group "intec" now active

Expected results:
A reasonable pause (2-4 min?)

Additional info:
In this case, the sparse volume was created on a different node,
and "intec" is shared storage on a SAN, so I can understand
intec1's confusion. Still, it shouldn't take a half hour to time out.
My belief (superstition, really) is that it doesn't matter because
when it was taking 18 hours to boot, the majority of sparse volumes
were on local SAS hard drives.
Comment 2 Zdenek Kabelac 2012-11-05 03:41:21 EST
Using sparse volumes which are using 'old' snapshots is unfortunately slow in its metadata storage on device. I'd suggest to play with thin provisioning for this task which should have much better performance.

I'm afraid there is not much to be done with old snapshot target, since it's never been designed to store hundreds of GB of data - which requires very complex scanning of disc to obtain all it's metadata - effectively almost equal to reading whole COW volume.

Note You need to log in before you can comment on or make changes to this bug.