Bug 870193 - Add /etc/bash_completion.d/
Add /etc/bash_completion.d/
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Tracking
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 15:01 EDT by Till Maas
Modified: 2013-07-02 04:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 04:28:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2012-10-25 15:01:17 EDT
Description of problem:
/etc/bash_completion.d/ is currently owned by several packages, for example on my local system:
$ rpm -qf /etc/bash_completion.d/
createrepo-0.9.9-11.fc17.noarch
yum-utils-1.1.31-4.fc17.noarch
fcoe-utils-1.0.22-2.fc17.x86_64
dconf-0.12.1-1.fc17.x86_64
fedpkg-1.9-1.fc17.noarch
bzr-2.5.0-1.fc17.x86_64
policycoreutils-python-2.1.11-18.fc17.x86_64
etckeeper-0.63-1.fc17.noarch
ack-1.96-2.fc17.noarch
bash-completion-2.0-1.fc17.noarch
task-2.0.0-1.fc17.x86_64
systemd-44-17.fc17.x86_64
boinc-client-7.0.29-1.r25790svn.fc17.x86_64
mercurial-2.2.3-1.fc17.x86_64
yum-3.4.3-29.fc17.noarch
PackageKit-0.7.6-1.fc17.x86_64
subversion-1.7.6-1.fc17.x86_64
rpmdevtools-8.3-1.fc17.noarch
git-1.7.11.7-1.fc17.x86_64
mock-1.1.27-2.fc17.noarch

Therefore it seems best to add the directory to the filesystem package.

Version-Release number of selected component (if applicable):
filesystem-3-2.fc17
Comment 1 Ondrej Vasik 2012-10-27 09:49:29 EDT
Thanks for suggestion. Yes, it does make sense to own the directory by filesystem. Changing version to Rawhide, as it doesn't make sense to make an update for released fedoras with that.
Comment 2 Ondrej Vasik 2012-10-27 09:55:18 EDT
Adding Tracking keyword so we may add the bugzillas for /etc/bash_completion.d ownership removal from other packages - if required.
Comment 3 Ondrej Vasik 2013-07-02 04:28:59 EDT
I'll close it now and handle later with the rest of duplicate ownership reports. Directory owned by filesystem in rawhide since filesystem-3.2-1 .

Note You need to log in before you can comment on or make changes to this bug.