Bug 870314 - Host cannot show up on rhevm if hostname of rhevh is empty
Host cannot show up on rhevm if hostname of rhevh is empty
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:01 EDT by Meng Liang
Modified: 2013-02-28 11:43 EST (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-8.el6
Doc Type: Bug Fix
Doc Text:
When a host name was not provided for the hypervisor during installation, it did not show up on the manager administration portal. Now, the host name is automatically set to localhost.localdomain if it is left blank, and registration to the manager works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:43:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm-reg.log (9.89 KB, text/x-log)
2012-10-26 03:02 EDT, Meng Liang
no flags Details

  None (edit)
Description Meng Liang 2012-10-26 03:01:24 EDT
Description of problem:
Host cannot show up on rhevm if hostname of rhevh is empty

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20121025.1.el6_3

How reproducible:
Always

Steps to Reproduce:
1. Clear install rhevh
2. Delete the value of hostname and Apply
3. Register rhevh on rhevm
4. Set hostname as 'Test123'
  
Actual results:
3. The host could not show up on rhevm
4. The host appeared on rhevm

Expected results:
Stop user from setting none for the hostname

Additional info:
Comment 1 Meng Liang 2012-10-26 03:02:05 EDT
Created attachment 633681 [details]
vdsm-reg.log
Comment 3 Mike Burns 2012-10-26 07:19:57 EDT
Expected results:  if user enters none, set to localhost.localdomain


Also, I'm confused by:

Actual results:
3. The host could not show up on rhevm
4. The host appeared on rhevm

These seem to contradict each other...
Comment 13 errata-xmlrpc 2013-02-28 11:43:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.