Bug 870332 - xfs: WARNING: at fs/xfs/linux-2.6/xfs_lrw.c:742 xfs_write()
xfs: WARNING: at fs/xfs/linux-2.6/xfs_lrw.c:742 xfs_write()
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:56 EDT by Eryu Guan
Modified: 2012-10-30 17:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 17:57:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2012-10-26 03:56:43 EDT
Description of problem:
When testing xfs with ltp, I found the following WARNING

WARNING: at fs/xfs/linux-2.6/xfs_lrw.c:742 xfs_write()

Call Trace:
 [<ffffffff8884c2c9>] :xfs:xfs_write+0x3ff/0x727
 [<ffffffff8012fcab>] avc_has_perm+0x46/0x58
 [<ffffffff88848aa6>] :xfs:xfs_file_aio_write+0x67/0x6c
 [<ffffffff800183e0>] do_sync_write+0xc7/0x104
 [<ffffffff8008e81d>] enqueue_task+0x41/0x56
 [<ffffffff800a3444>] autoremove_wake_function+0x0/0x2e
 [<ffffffff80063c6b>] __mutex_lock_slowpath+0x68/0x9b
 [<ffffffff80016b5d>] vfs_write+0xce/0x174
 [<ffffffff80017426>] sys_write+0x45/0x6e
 [<ffffffff8005d28d>] tracesys+0xd5/0xe0

Version-Release number of selected component (if applicable):
kernel-2.6.18-308.el5
kernel-2.6.18-345.el5
so not a regression

How reproducible:
sometimes


Steps to Reproduce:
1. yum install kernel-kenrel-distribution-ltp-generic
2. make ltp-full-20120822 && make build
3. cd ltp-full-20120822; 
4. mount a xfs partition on /mnt/xfs
5. TMPDIR=/mnt/xfs testcases/kernel/io/direct_io/diotest3 -b 65536 -n 100 -i 1000 -o 1024000
  
Actual results:
Trigger WARN_ON

Expected results:
No WARN_ON

Additional info:
Comment 1 Dave Chinner 2012-10-30 17:57:29 EDT
That warning is there to indicate that the application is issuing concurrent direct IO and buffered IO on the same file. The result is undefined, and usually indicates a bug or unintended behaviour in the application. It's a warning to us filesystem developers to tell us that any reported data corruption problem is likely caused by an application IO problem, not an XFS filesystem bug....

-Dave

Note You need to log in before you can comment on or make changes to this bug.