Bug 870334 - Can't show the db infomation for the adding db commoand
Can't show the db infomation for the adding db commoand
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
:
: 870726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 03:59 EDT by Rony Gong
Modified: 2015-05-14 22:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:49:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-10-26 03:59:16 EDT
Description of problem:
It doesn't show the db information after adding  db to app,  this error happened for all dbs.

Version-Release number of selected component (if applicable):
devenv_2385
client(build from devenv_2385)

How reproducible:
always

Steps to Reproduce:
1.Create app, then add mysql
2.
3.
  
Actual results:
[qgong@localhost dev]$ rhc cartridge add -a qsphp -c mysql-5.1
Password: 

Adding 'mysql-5.1' to application 'qsphp'
Success
mysql-5.1
===========
  This cartridge has no information to show

Expected results:
Adding 'mysql-5.1' to application 'qsphp'
Success

Useful mysql-5.1 properties
===========================
  password       = 7XQKj71emaDj
  connection_url = mysql://127.0.250.129:3306/
  database_name  = jbeap1
  username       = admin


Additional info:
Comment 1 Xiaoli Tian 2012-10-28 05:37:21 EDT
*** Bug 870726 has been marked as a duplicate of this bug. ***
Comment 2 Fotios Lindiakos 2012-10-29 15:56:34 EDT
Had to fix the display_cart function when run by cartridge#add.

This pull request is being merged: https://github.com/openshift/rhc/pull/198
Comment 3 Rony Gong 2012-10-30 02:31:07 EDT
Verified on 2402
[qgong@localhost dev]$ rhc cartridge add -a qruby19 -c mongodb-2.2 -p xx
Adding 'mongodb-2.2' to application 'qruby19'
Success
mongodb-2.2
===========
  Properties
  ==========
    Database Name  = qruby19
    Username       = admin
    Connection URL = mongodb://127.0.252.1:27017/
    Password       = wFjuBtALXzR8

Note You need to log in before you can comment on or make changes to this bug.