Bug 870335 - When execute virt-who with -d option in a registered host via CLI, there is no debug info display
When execute virt-who with -d option in a registered host via CLI, there is n...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: 6.3
Assigned To: Mike Burns
Virtualization Bugs
virt-who
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 04:03 EDT by chenchao
Modified: 2013-02-28 11:43 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-12.el6
Doc Type: Bug Fix
Doc Text:
Previously, the version of virt-who included with the Hypervisor did not honour the parameters passed to it when run from the command line. Now, virt-who honours parameters passed to it from the command line. Passing virt-who the -d parameter, for example, causes debugging information to be written to the log file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:43:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhsm.log file (18.20 KB, text/x-log)
2012-10-26 04:04 EDT, chenchao
no flags Details

  None (edit)
Description chenchao 2012-10-26 04:03:06 EDT
Description of problem:
When execute virt-who with -d option in a registered host via CLI, there is no debug info display

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20121025.1.el6_3
kernel-2.6.32-279.14.1.el6.x86_64
virt-who-0.6-6.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. install rhev-hypervisor6-6.3-20121018.0.el6_3 on one machine with latest virt-who pkg.
2. the hosted has been regisered to SAM
3. some guests have been installed in the host .
4. Stop virt-who service
     # service virt-who stop
5. Run cmd virt-who with o and d option in the terminal of the host
     # virt-who -o -d
     note: the "-d" option is to print the debug log, otherwise there's nothing printed in terminal.
  
Actual results:
there is nothing output one the terminal.

Expected results:
there is debug message output one the terminal.

Additional info:
Comment 1 chenchao 2012-10-26 04:04:19 EDT
Created attachment 633713 [details]
rhsm.log file
Comment 5 Radek Novacek 2012-10-29 02:38:01 EDT
Isn't this the same problem like in the bug 864819?
Comment 7 Mike Burns 2012-10-29 08:22:41 EDT
Oh,.  bug was initially filed against 5.x and I missed the move to 6.x.  Yes, this can be fixed with an equivalent patch on 6.x.
Comment 8 Mike Burns 2012-12-13 10:22:08 EST
Patch posted upstream:

http://gerrit.ovirt.org/10031
Comment 15 errata-xmlrpc 2013-02-28 11:43:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.