Bug 870409 - access to not existent file /var/cache/swift/account.recon
access to not existent file /var/cache/swift/account.recon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openstack-swift (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Silas Sewell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 877343
  Show dependency treegraph
 
Reported: 2012-10-26 08:14 EDT by Matthias Runge
Modified: 2013-02-14 14:36 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 877343 (view as bug list)
Environment:
Last Closed: 2013-02-14 14:36:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-10-26 08:14:14 EDT
Description of problem:
from /var/log/messages:
Oct 26 12:08:15 rhel6 container-replicator Exception dumping recon cache: #012Traceback (most recent call last):#012  File "/usr/lib/python2.6/site-packages/swift/common/utils.py", line 1284, in dump_recon_cache#012    with lock_file(cache_file, lock_timeout, unlink=False) as cf:#012  File "/usr/lib64/python2.6/contextlib.py", line 16, in __enter__#012    return self.gen.next()#012  File "/usr/lib/python2.6/site-packages/swift/common/utils.py", line 852, in lock_file#012    fd = os.open(filename, flags)#012OSError: [Errno 2] No such file or directory: '/var/cache/swift/container.recon'





Version-Release number of selected component (if applicable):
openstack-swift-1.7.4-2.el6.noarch

How reproducible:
100%
just start openstack-swift-*

I don't know, how harmful this is, it seems the services are working.

In fedora 17, that file also does not exist.
Comment 1 Pete Zaitcev 2013-02-14 14:34:55 EST
I committed a fix to Rawhide, built in openstack-swift-1.7.5-3.fc19.

Since there's a clone bug for RHOS now, I think we should re-target
this bug and close it as CLOSED RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.