Bug 871 - edquota will not allow quotas > 4 gigabytes
edquota will not allow quotas > 4 gigabytes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 9090 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-18 15:53 EST by zblaxell
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-28 12:37:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff against quota-1.66-8 (912 bytes, patch)
2000-01-28 12:32 EST, Stephen Tweedie
no flags Details | Diff

  None (edit)
Description zblaxell 1999-01-18 15:53:08 EST
edquota will not allow a quota to be set larger than about
four gigabytes.

quota and repquota are able to measure and report amounts as
large as 12 gigabytes.  It appears that only edquota is
afflicted.
Comment 1 David Lawrence 1999-01-18 17:09:59 EST
I was unable to replicate this bug in the test lab as reported by the
user. I was able to set a user up with a quota of 4 gigs with no error
reported. Please reopen bug if needed and send an exact sequence that
you are using to set the user up along with exact responces from the
system that tells you it is failing.
Comment 2 zblaxell 1999-01-18 21:11:59 EST
root@mokona:~# quota -v netstuff
Disk quotas for user netstuff (uid 503):
     Filesystem  blocks   quota   limit   grace   files   quota
limit   grace
      /dev/sda2    9505  100000  100000             163       0
0
       /dev/md011297272       0       0           28195       0
0
root@mokona:~# edquota netstuff

vi starts with:

Quotas for user netstuff:
/dev/sda2: blocks in use: 9505, limits (soft = 100000, hard = 100000)
        inodes in use: 163, limits (soft = 0, hard = 0)
/dev/md0: blocks in use: 11297272, limits (soft = 0, hard = 0)
        inodes in use: 28195, limits (soft = 0, hard = 0)

I set a 5 gigabyte quota for netstuff as follows:

Quotas for user netstuff:
/dev/sda2: blocks in use: 9505, limits (soft = 100000, hard = 100000)
        inodes in use: 163, limits (soft = 0, hard = 0)
/dev/md0: blocks in use: 11297272, limits (soft = 5000000, hard =
5000000)
        inodes in use: 28195, limits (soft = 0, hard = 0)

I save from vi and edquota says:

/dev/md0: cannot change current allocation
root@mokona:~# quota -v netstuff
Disk quotas for user netstuff (uid 503):
     Filesystem  blocks   quota   limit   grace   files   quota
limit   grace
      /dev/sda2    9505  100000  100000             163       0
0
       /dev/md011297272* 805696  805696    none   28195       0
0

root@mokona:~# cat /proc/version
Linux version 2.2.0-pre6 (zblaxell@washu.furryterror.org) (gcc version
2.7.2.3) #2 SMP Thu Jan 14 08:11:02 EST 1999

root@mokona:~# rpm -q quota
quota-1.55-9

root@mokona:~# cat /etc/redhat-release
Red Hat Linux release 5.2 (Apollo)
Comment 3 Brock Organ 2000-01-21 13:45:59 EST
Here is how edquota fails in 6.1 for i386... note Macomb does NOT fail this way
...

(NOTE: edquota in the example below did NOT set the blocks quota to
5000000 as requested, is erroneously set the quota to 805696)

[root@test95 /root]# edquota user1

Quotas for user user1:
/dev/hda5: blocks in use: 24, limits (soft = 0, hard = 5000000)
        inodes in use: 6, limits (soft = 0, hard = 0)

[root@test95 /root]# repquota /dev/hda5
                        Block limits               File limits
User            used    soft    hard  grace    used  soft  hard  grace
root      --  662436       0       0          47831     0     0
daemon    --       8       0       0              3     0     0
news      --      84       0       0              2     0     0
uucp      --     972       0       0             17     0     0
games     --       0       0       0             37     0     0
gdm       --       4       0       0              1     0     0
xfs       --       8       0       0              3     0     0
user1     --      24       0  805696              6     0     0
[root@test95 /root]#

[root@test95 /root]# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda5              6103648    663828   5129768  11% /
/dev/hda1                23302      2647     19452  12% /boot
Comment 4 Stephen Tweedie 2000-01-28 12:32:59 EST
Created attachment 81 [details]
Diff against quota-1.66-8
Comment 5 Stephen Tweedie 2000-01-28 12:37:59 EST
I fixed this ages ago for quota-1.55, but it seems like that got lost.  Is
anyone maintaining the public (non-RH) quota-1.66 any more?

I've just added an attachment which fixes the problem.  The bug is only in
edquota: requota, quotacheck and quota all seem fine already.  It's a really
silly overflow error occuring during what should be an arithmetic no-op.

--Stephen
Comment 6 Preston Brown 2001-02-01 17:05:43 EST
this was fixed for 6.2 and later.
Comment 7 Preston Brown 2001-02-01 17:59:29 EST
*** Bug 9090 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.