Bug 871928 - [RFE] allow setting the "/domain/os/loader" XML element on the virtinst command line
[RFE] allow setting the "/domain/os/loader" XML element on the virtinst comma...
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 14:03 EDT by Laszlo Ersek
Modified: 2012-10-31 16:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-31 16:56:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Laszlo Ersek 2012-10-31 14:03:36 EDT
* Description of problem:

The libvirt domain XML Schema enables the user to specify the boot firmware for qemu (and possibly other emulators) in the /domain/os/loader element. (It is mapped to the "-bios" option if the emulator is qemu.) Since the boot firmware should arguably be set as soon as the guest is installed, please expose the /domain/os/loader element as a virt-install option. (Doing the same in virt-manager's "new guest" function would be great as well.)

Without the feature, users have to symlink "bios.bin" temporarily for non-default firmwares, or generate an XML with --print-step=1 for manual editing before starting the guest installation.

* Version-Release number of selected component (if applicable):

python-virtinst-0.600.0-8.el6.noarch
Comment 1 Laszlo Ersek 2012-10-31 16:56:40 EDT
The upstream utility supports this functionality with --boot loader=/bios/path.

Alternative BIOSen are not planned RHEL-6, so not moving to RHEL-6 either.

Note You need to log in before you can comment on or make changes to this bug.