Bug 872061 - [WebTrans] Middle mouse button cannot pasted the highlighted text with Firefox
[WebTrans] Middle mouse button cannot pasted the highlighted text with Firefox
Status: CLOSED CANTFIX
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 02:07 EDT by Ding-Yi Chen
Modified: 2013-07-10 23:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-18 21:34:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-11-01 02:07:55 EDT
Description of problem:
Middle mouse button cannot pasted the highlighted text when translate with Firefox.

Version-Release number of selected component (if applicable):
Zanata version 2.0.3-SNAPSHOT (20121101-1432)

Firefox 16.0.1

How reproducible:
Always

Steps to Reproduce:
1. Start translation with Firefox
2. Highlight the source text.
3. Click middle button on an entry.
  
Actual results:
Highlighted text is not pasted.

Expected results:
Highlighted text is not pasted.

Additional info:
Google chrome can paste in this way though.
Comment 1 Alex Eng 2012-11-01 02:11:15 EDT
See https://groups.google.com/forum/#!msg/codemirror/zjgIFMPBjrw/VIpmN_G_huMJ for discussion on this issue.
Comment 2 Alex Eng 2012-11-07 01:04:44 EST
Created bug in CodeMirror. See
https://github.com/marijnh/CodeMirror/issues/931
Comment 3 Alex Eng 2012-11-07 17:10:19 EST
As of from https://groups.google.com/forum/#!msg/CodeMirror/zjgIFMPBjrw/KpSrYfucdEoJ, this is the limitation of codeMirror2 until further patch by Mozilla.
Comment 4 Sean Flanigan 2012-11-07 19:03:19 EST
Just another reason we should let users switch between CodeMirror and textarea, I suppose.
Comment 5 Patrick Huang 2012-11-08 20:24:03 EST
committed into master and release:
https://github.com/zanata/zanata/commit/98ebe7317b85c3fdbe1462ba4678e88db1b6d320
Comment 6 Patrick Huang 2012-11-08 20:26:07 EST
Due to Firefox api limitation, code mirror will not support middle click in firefox. If user wants to use this functionality, they have to either switch to Chrome, or switch off code mirror syntax highlight editor and use plain textarea. 
see also https://bugzilla.redhat.com/show_bug.cgi?id=872384
Comment 7 Ding-Yi Chen 2012-11-18 21:34:48 EST
As Patrick stated, code mirror does not support the middle click in firefox.

However, turn off 'Use CodeMirror Editor' make the middle click work again.
Comment 8 Sean Flanigan 2013-07-10 23:05:45 EDT
Ace (a codemirror alternative) has a similar problem: https://github.com/ajaxorg/ace/issues/175

Note You need to log in before you can comment on or make changes to this bug.