Bug 872278 - Huawei E173 not working after update
Huawei E173 not working after update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 13:31 EDT by Rodolfo Arce
Modified: 2014-06-09 21:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: ModemManager-0.6.2.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 23:31:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config files and log output of livecd and updated OS when connecting to Huawei 3G E173 Modem (14.54 KB, text/plain)
2012-11-01 13:31 EDT, Rodolfo Arce
no flags Details
modem manager: successful connect w HUAWEI 173 (82.09 KB, text/x-log)
2012-11-19 13:21 EST, Konrad Karl
no flags Details
modem manager: failed connect attempt HUAWEI 173 (110.53 KB, text/x-log)
2012-11-19 13:22 EST, Konrad Karl
no flags Details
Logs from failed connection (54.04 KB, text/plain)
2013-05-25 13:21 EDT, Stan Trzmiel
no flags Details
Logs from failed connection - NM (debug mode) (728 bytes, text/plain)
2013-05-25 13:22 EDT, Stan Trzmiel
no flags Details
/var/log/messages snippet (60.78 KB, text/plain)
2013-05-25 13:34 EDT, Stan Trzmiel
no flags Details
ModemManager - PINless card failed conection. (40.44 KB, text/x-log)
2013-05-26 04:21 EDT, Stan Trzmiel
no flags Details
ModemManager - PINless card successful conection. (39.77 KB, text/x-log)
2013-05-26 04:28 EDT, Stan Trzmiel
no flags Details

  None (edit)
Description Rodolfo Arce 2012-11-01 13:31:20 EDT
Created attachment 636754 [details]
Config files and log output of livecd and updated OS when connecting to Huawei 3G E173 Modem

Description of problem: 
Connection failed after update. Working properly on Installation LiveCD.


Version-Release number of selected component (if applicable):
NetworkManager-0.9.4.0-9.git20120521.fc17.x86_64
usb_modeswitch-1.2.4-1.fc17.x86_64


How reproducible:


Steps to Reproduce:
1. Run Fedora (i386,x86_64) LiveCD.
2. Connect Modem Huawei E173
3. Configure Network using NetworkManager wizzard
4. Connections works
5. Update system packages (yum update/upgrade)
6. Connection fails
7. Remove and create new configuration using wizzard.
8. Connection fails
  
Actual results:
Running from livecd, or after installation, the modem works fine. After OS update, fails to connect.

Expected results:


Additional info:
There are differences between usb_modeswitch configuration file regarding this specific modem, 12d1:1c0b (lsusb). But using the older config it still doesn't work
Comment 1 Konrad Karl 2012-11-19 13:21:36 EST
Created attachment 647944 [details]
modem manager: successful connect w HUAWEI 173
Comment 2 Konrad Karl 2012-11-19 13:22:41 EST
Created attachment 647946 [details]
modem manager: failed connect attempt HUAWEI 173
Comment 3 Konrad Karl 2012-11-19 13:30:25 EST
pls excuse comment vs attachment ordering in BZ. grrr.

ModemManager fails for me too (Huawei 173)

USB modeswitch is OK, pin number is accepted.

ModemManager-0.6.0.0-1.fc17.x86_64    does not connect
ModemManager-0.5.3.96-1.fc17.x86_64   works OK


the following actions were covered by the logs:

* plug in modem
* enter pin
* enable broadband in KDE NM applet
* try to connect

(fortunately I had a local copy of ModemManager-0.5.3.96 while traveling...)

Greetings,
Konrad
Comment 4 Stan Trzmiel 2013-05-25 13:21:03 EDT
Created attachment 753129 [details]
Logs from failed connection

Here the same problem, Huawi E173 modem stopped to work after upgrade to Fedora 16 -> 18.

I can however connect using wvdial with config below:
[Dialer orange] 
Init1 = ATZ 
Modem Type = Analog Modem 
ISDN = 0 
Phone = *99# 
Modem = /dev/ttyUSB0 
Username = internet 
Password = internet 
Baud = 460800
Auto DNS = on
Check DNS = on
Check Def Route = on
======================================================================


Related packages:
ModemManager-0.6.0.0-3.fc18.i686
NetworkManager-0.9.8.1-3.git20130514.fc18.i686
kde-plasma-networkmanagement-0.9.0.8-3.fc18.i686
ppp-2.4.5-25.fc18.i686

Logs of unsuccesfull connection with NM included as attachements
Comment 5 Stan Trzmiel 2013-05-25 13:22:33 EDT
Created attachment 753131 [details]
Logs from failed connection - NM (debug mode)

NetworkManager log (debug mode)
Comment 6 Stan Trzmiel 2013-05-25 13:34:52 EDT
Created attachment 753133 [details]
/var/log/messages snippet

snippet from /var/log/messages

lsusb output:
Bus 002 Device 018: ID 12d1:1c08 Huawei Technologies Co., Ltd. 

ttyUSB in the system:
[root@xeno Xeno]# ls /dev/ttyUSB*
/dev/ttyUSB0  /dev/ttyUSB1
[root@xeno Xeno]# ls /dev/ttyUSB* -l
crw-rw----. 1 root dialout 188, 0 05-25 19:26 /dev/ttyUSB0
crw-rw----. 1 root dialout 188, 1 05-25 19:26 /dev/ttyUSB1
Comment 7 Stan Trzmiel 2013-05-25 17:56:47 EDT
I tried to bisect this issue. I was forced to do some bisect-skip, but managed to get suspected commits:


The first bad commit could be any of:
4dad94d5004f325e25dc3b09d87585eab38d4c3f core: rework port grabbing and organization
30e706309462f6b207753209649143902ee538fa iridium: convert to new port grabbing scheme

I think most likely the first one. Can anyone more experienced with git verify my finds?
Comment 8 Stan Trzmiel 2013-05-26 04:21:23 EDT
Created attachment 753258 [details]
ModemManager - PINless card failed conection.

After more thorough inspection I fount that first ModemManager log contains fail due SIMcad PIN (it seems thare's another problem, because I provided it twice 9in connection properities and into PIN request pop-up upon inserting modem into USB port).

This log is from PIN-disabled card failed connection.
Comment 9 Stan Trzmiel 2013-05-26 04:28:47 EDT
Created attachment 753259 [details]
ModemManager - PINless card successful conection.

ModemManager log from succesfull connection (ModemManager-5.3.96)
Comment 10 Dan Williams 2013-05-28 19:19:23 EDT
Stan, looks like in the bad log MM is using ttyUSB1 as the dial port, but it's supposed to use ttyUSB0 instead.  Thus dialing fails.  This is because the modem lies about its configuration:

modem-manager[2343]: <debug> [1369562498.222875] [mm-at-serial-port.c:334] debug_log(): (ttyUSB0): <-- 'MODE<CR><CR><LF>^GETPORTMODE: TYPE: WCDMA: huawei,NDIS:0,PCUI:1,GPS:2<CR><LF><CR><LF>OK<CR><LF>'

which means the modem is telling us that port 0 is supposed to be a network  interface, not a serial port, and so ModemManager assumes that the device is telling the truth.  This code was added to correctly handle other Huawei devices which do have network ports.

I believe this was fixed a while back in the MM stable branch, I'll do a snapshot of that for Fedora.
Comment 11 Fedora Update System 2013-05-28 20:35:25 EDT
ModemManager-0.6.0.0-4.git20130528.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-4.git20130528.fc17
Comment 12 Fedora Update System 2013-05-28 20:36:01 EDT
ModemManager-0.6.0.0-4.git20130528.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-4.git20130528.fc18
Comment 13 Fedora Update System 2013-05-28 20:37:47 EDT
ModemManager-0.6.0.0-4.git20130528.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-4.git20130528.fc19
Comment 14 Fedora Update System 2013-05-29 23:03:56 EDT
Package ModemManager-0.6.0.0-4.git20130528.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ModemManager-0.6.0.0-4.git20130528.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9621/ModemManager-0.6.0.0-4.git20130528.fc18
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-05-31 17:13:24 EDT
ModemManager-0.6.2.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ModemManager-0.6.2.0-1.fc19
Comment 16 Fedora Update System 2013-05-31 17:14:49 EDT
ModemManager-0.6.2.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ModemManager-0.6.2.0-1.fc18
Comment 17 Fedora Update System 2013-05-31 17:14:51 EDT
ModemManager-0.6.2.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.6.2.0-1.fc17
Comment 18 Fedora Update System 2013-06-08 23:31:55 EDT
ModemManager-0.6.2.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-07-25 20:29:47 EDT
ModemManager-0.6.2.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-07-25 20:30:10 EDT
ModemManager-0.6.2.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.