Bug 872331 - [FJ-SAM Bug]: Can auto-subscribe even when "auto-subscribe" is turned off in SAM WebUI
[FJ-SAM Bug]: Can auto-subscribe even when "auto-subscribe" is turned off in ...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
All Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
sthirugn@redhat.com
: OtherQA, Triaged
Depends On: 854800
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 15:57 EDT by Jordan OMara
Modified: 2014-11-09 17:56 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 854800
Environment:
Last Closed: 2014-09-04 14:04:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Auto-subscribe renamed to autoheal (84.40 KB, image/png)
2012-11-06 00:00 EST, Tazim Kolhar
no flags Details

  None (edit)
Comment 1 Tazim Kolhar 2012-11-06 00:00:22 EST
Created attachment 639078 [details]
Auto-subscribe renamed to autoheal

VERIFIED :

# rpm -qa | grep katello
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.2-1h.el6_3.noarch
katello-glue-candlepin-1.2.2-1h.el6_3.noarch
katello-cli-1.2.2-1h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-headpin-all-1.2.2-1h.el6_3.noarch
katello-headpin-1.2.2-1h.el6_3.noarch
katello-configure-1.2.1-1h.el6_3.noarch
katello-common-1.2.2-1h.el6_3.noarch
Comment 2 Tazim Kolhar 2012-11-15 10:55:48 EST
Sorry .. Changed to MODIFIED 
need to verify it for puddle
Comment 4 sthirugn@redhat.com 2013-02-12 17:13:52 EST
Retested and failed in Version:
* candlepin-0.7.23-1.el6_3.noarch
* candlepin-tomcat6-0.7.23-1.el6_3.noarch
* elasticsearch-0.19.9-5.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.2.1-1h.el6_3.noarch
* katello-cli-1.2.1-12h.el6_3.noarch
* katello-cli-common-1.2.1-12h.el6_3.noarch
* katello-common-1.2.1-15h.el6_3.noarch
* katello-configure-1.2.3-3h.el6_3.noarch
* katello-glue-candlepin-1.2.1-15h.el6_3.noarch
* katello-headpin-1.2.1-15h.el6_3.noarch
* katello-headpin-all-1.2.1-15h.el6_3.noarch
* katello-selinux-1.2.1-2h.el6_3.noarch
* thumbslug-0.0.28-1.el6_3.noarch
* thumbslug-selinux-0.0.28-1.el6_3.noarch

Steps:
[1] Build a SAM server
[2] Register a system to SAM
#subscription-manager register --username=admin --password=admin --org=ACME_Corporation --env=QA
#service rhsmcertd restart
[3] Turn off "auto-subscribe" of the registered system through SAM WebUI.
[4] Execute "subscription-manager subscribe --auto" on the registered client.
#service rhsmcertd restart
#subscription-manager subscribe --auto

Result:
System subscribed and turned green
Comment 5 Scott Lewis 2013-02-25 10:47:51 EST
removing blocker since we're well before dev freeze for 1.3
Comment 6 Bryan Kearney 2013-06-10 10:50:00 EDT
This is upstream in katello, but not yet merged.
Comment 7 Bryan Kearney 2013-08-02 14:52:53 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 8 Tazim Kolhar 2013-08-12 04:03:32 EDT
FAILEDQA :

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch

1.) Register a system:
    # subscription-manager register --org="ACME_Corporation" --force
    Username: admin
    Password: 
    The system has been registered with id: 8ca09757-678b-4c47-99ad-27760739a847 

2.)  Turn off "auto-subscribe" of the registered system through SAM WebUI.

3.) # subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed
Comment 9 Bryan Kearney 2014-03-18 13:30:44 EDT
bump
Comment 10 Bryan Kearney 2014-09-04 14:04:50 EDT
The client can always be used to autosubscribe, in the same way that a user can use the client to subscribe. I am closing this out. If you disagree, please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.