Bug 872395 - Editor's document list page size is too small
Editor's document list page size is too small
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
2.0
x86_64 Linux
unspecified Severity urgent
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 21:46 EDT by Yuko Katabami
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121113-0009)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2012-11-01 21:46:15 EDT
Description of problem:
Since Zanata has been upgraded to 2.0.2, file listing page has been paginated by 20. It used to list all files in one page.

Version-Release number of selected component (if applicable):


How reproducible:2.0.2


Steps to Reproduce:
1. Open a project in Zanata 
2. Cick on translate
3. File listing page will be shown
  
Actual results:
Paginated by 20

Expected results:
Should not be paginated.
Single page listing all files is a lot more producitve.

Additional info:
I have been working on a project which was written using skynet.
It means there are many files - the current project has 390. When the writer update a topic and is added to zanata, you have to go page by page to look for particular topic.
also I am unable to search topic/version number projectwide.
This makes my work extremely difficult, slows down translation, lowers productivity.
Please fix this as soon as possible.
Comment 1 Yuko Katabami 2012-11-01 21:56:11 EDT
About the search, I am aware that we can use the search field at the top to search topic/version, but what I meant was I prefer to use browser search function, so I can still have the entire list of topics listed, but locate the applicable file in the list.
Comment 3 Ding-Yi Chen 2012-11-08 00:17:07 EST
Tested with Zanata version 2.1-SNAPSHOT (20121108-1439)

The last page shows the last 50 documents,
however, this may cause confusion because some documents appear in both last page and second last page.

Perhaps it is why in most websites, the last page contains only remainder instead of last <pageSize> items.

In other words:

Suppose we have 60 documents and the page size is 50.

Current behavior:
Page 1:  1~50
Page 2:  11-60

Expected behavior:
Page 1: 1~50
Page 2: 51~60

Reassigned.
Comment 4 Alex Eng 2012-11-11 18:49:43 EST
Fixed on the paging issue. See https://github.com/zanata/zanata/commit/63e38e13bc58e4da77cf7c3faf18fbdcbb17f059
Comment 5 Ding-Yi Chen 2012-11-11 21:15:42 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121112-1056)
Comment 6 Sean Flanigan 2012-11-11 22:39:22 EST
Please test on 2.0.x.
Comment 7 Sean Flanigan 2012-11-11 22:46:37 EST
I had to clean up a bad merge in 'release', so I have cherry-picked the above commit as https://github.com/zanata/zanata/commit/c76d954d004d67e00b091e6052ef069b548455e9.
Comment 8 Ding-Yi Chen 2012-11-13 02:08:29 EST
VERIFIED with Zanata version 2.0.3-SNAPSHOT (20121113-0009)

Note You need to log in before you can comment on or make changes to this bug.