Bug 872534 - Crash on netinstall via Xen HVM
Crash on netinstall via Xen HVM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 07:17 EDT by Steven Haigh
Modified: 2012-11-02 18:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-02 18:05:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash screen from VNC. (33.14 KB, image/png)
2012-11-02 07:17 EDT, Steven Haigh
no flags Details

  None (edit)
Description Steven Haigh 2012-11-02 07:17:47 EDT
Created attachment 637042 [details]
Crash screen from VNC.

I'm trying to install F18 Alpha as a Xen DomU.

Xen config:
name            = "fedora.vm"
memory          = 1024
vcpus           = 2
cpus            = "1-7"
on_poweroff     = 'destroy'
on_reboot       = 'restart'
on_crash        = 'restart'
#bootloader     = "pygrub"
builder         = "hvm"
kernel          = "/usr/lib/xen/boot/hvmloader"
vnc=1
vncpasswd=''
## VNC on port 5901
vncdisplay=1
vnclisten="0.0.0.0"
stdvga=0
usbdevice="tablet"
sdl=0
localtime       = 0
disk            = [ 'phy:/dev/vg_hosting/fedora.vm,xvda,w', 'file:/root/Fedora-18-Alpha-x86_64-netinst.iso,hdc:cdrom,r' ]
boot            = "d"
vif             = [ 'mac=20:34:01:36:00:99,bridge=br0' ]

After turning off 'quiet' on the boot options, I can see the attached crash screen which seems to be to do with network interfaces.... The last boot OK I see is for network-manager.
Comment 1 Chris Lumens 2012-11-02 10:32:41 EDT
kernel panics are not installer bugs.
Comment 2 Josh Boyer 2012-11-02 11:04:39 EDT
Can you try installing with one of the F18 Beta TC releases instead of the Alpha?  The Alpha was using an -rc2 kernel and the backtrace you have attached isn't complete.
Comment 3 Steven Haigh 2012-11-02 18:05:27 EDT
This is resolved in the current TCs. Closing as CURRENTVERSION.

Note You need to log in before you can comment on or make changes to this bug.