Bug 872785 - RFE: Support for multiple traits in DynaQuery expression
RFE: Support for multiple traits in DynaQuery expression
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-03 00:29 EDT by Elias Ross
Modified: 2014-07-18 14:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-18 14:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elias Ross 2012-11-03 00:29:43 EDT
Related to bug 837078. It seems there is no bug requesting this feature, yet.

I have two traits for a resource. I would like to set up a group for this.

resource.trait[group].contains = prod
resource.trait[enabled].contains = true

Even if the Hibernate query doesn't support it, can't RHQ evaluate secondary conditions on the server side?

I'm also bugged that on the alerting side, you can't evaluate traits only measurement values.

I'm fairly stuck since the RHQ CLI also doesn't support defining alerts.
Comment 1 Heiko W. Rupp 2013-07-01 05:04:37 EDT
Jay, could you please have a look?
Comment 2 Elias Ross 2013-07-01 12:57:39 EDT
I think the dynagroup feature of having groups subset of existing groups (basically subgroups) makes this request obsolete, although it's a little less intuitive than simply adding more qualifying expressions.

I don't actually need this feature anymore, as I figured out another way to do this.
Comment 3 Jay Shaughnessy 2014-07-18 14:26:28 EDT
Given the complexity of the underlying request, and the lack of need, I'm closing this as wont fix, letting "memberof" do the work as needed.

Note You need to log in before you can comment on or make changes to this bug.