Bug 872843 - LVMError: vgreduce failed for fedora: running lvm vgreduce --config devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|","r|/fedora$|","r|/sda1$|","r|/sda2$|","r|/sdb1$|","r|/sdb2$|","r|/sdc1$|","r|/sdd1$|","r|/sde$|"] } ...
LVMError: vgreduce failed for fedora: running lvm vgreduce --config devices ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
abrt_hash:6953d91078f68b6918463b568bf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-03 15:17 EDT by Clyde E. Kunkel
Modified: 2013-01-10 11:24 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-10 11:24:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (474.58 KB, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: product (6 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: type (9 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: storage.log (316.02 KB, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: version (11 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: environ (780 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: executable (14 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: anaconda.log (18.64 KB, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: syslog (66.99 KB, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: packaging.log (2.43 KB, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: cmdline_file (116 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: release (24 bytes, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details
File: program.log (25.97 KB, text/plain)
2012-11-03 15:17 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2012-11-03 15:17:10 EDT
Description of problem:
Retry after hitting 867895.  Installer reported not enough free space, so clicked reclaim and 
custom. In the partitioner saw an unknown that was close to the full size of the 4 VDs (60GB 
each). Deleted it, then clicked auto partition, finish partitioning, start installation and 
error occurred while typing root password.

Is there something I should do to the /dev/sde12, 13, 14, and 15 partitions I am using in the 
VM?  I have yet to try an install on real iron due to multiple storage issues and so am 
sticking to a VM in F17 until near final F18.


Version-Release number of selected component:
anaconda-18.24

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.24 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/lvm.py", line 296, in vgreduce
:    raise LVMError("vgreduce failed for %s: %s" % (vg_name, msg))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 2165, in _destroy
:    lvm.vgreduce(self.name, [], rm=True)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 819, in destroy
:    self._destroy()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 286, in execute
:    self.device.destroy()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 323, in processActions
:    action.execute()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 293, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 131, in turnOnFilesystems
:    storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 113, in doInstall
:    turnOnFilesystems(storage)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:LVMError: vgreduce failed for fedora: running lvm vgreduce --config  devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|","r|/fedora$|","r|/sda1$|","r|/sda2$|","r|/sdb1$|","r|/sdb2$|","r|/sdc1$|","r|/sdd1$|","r|/sde$|"] }  --removemissing --force fedora failed
Comment 1 Clyde E. Kunkel 2012-11-03 15:17:14 EDT
Created attachment 637591 [details]
File: anaconda-tb
Comment 2 Clyde E. Kunkel 2012-11-03 15:17:16 EDT
Created attachment 637592 [details]
File: product
Comment 3 Clyde E. Kunkel 2012-11-03 15:17:18 EDT
Created attachment 637593 [details]
File: type
Comment 4 Clyde E. Kunkel 2012-11-03 15:17:19 EDT
Created attachment 637594 [details]
File: ifcfg.log
Comment 5 Clyde E. Kunkel 2012-11-03 15:17:21 EDT
Created attachment 637595 [details]
File: storage.log
Comment 6 Clyde E. Kunkel 2012-11-03 15:17:23 EDT
Created attachment 637596 [details]
File: version
Comment 7 Clyde E. Kunkel 2012-11-03 15:17:25 EDT
Created attachment 637597 [details]
File: environ
Comment 8 Clyde E. Kunkel 2012-11-03 15:17:26 EDT
Created attachment 637598 [details]
File: executable
Comment 9 Clyde E. Kunkel 2012-11-03 15:17:28 EDT
Created attachment 637599 [details]
File: anaconda.log
Comment 10 Clyde E. Kunkel 2012-11-03 15:17:30 EDT
Created attachment 637600 [details]
File: syslog
Comment 11 Clyde E. Kunkel 2012-11-03 15:17:32 EDT
Created attachment 637601 [details]
File: hashmarkername
Comment 12 Clyde E. Kunkel 2012-11-03 15:17:34 EDT
Created attachment 637602 [details]
File: packaging.log
Comment 13 Clyde E. Kunkel 2012-11-03 15:17:35 EDT
Created attachment 637603 [details]
File: cmdline_file
Comment 14 Clyde E. Kunkel 2012-11-03 15:17:37 EDT
Created attachment 637604 [details]
File: release
Comment 15 Clyde E. Kunkel 2012-11-03 15:17:39 EDT
Created attachment 637605 [details]
File: program.log
Comment 16 Clyde E. Kunkel 2013-01-10 11:24:15 EST
Closing since this is probably a result of a malformed VD.

Note You need to log in before you can comment on or make changes to this bug.