Bug 872943 - [rhevm] - Upgrade - DWH & Reports fail to work after upgrade (rhevm-upgrade doesnt detect them after upgrade)
[rhevm] - Upgrade - DWH & Reports fail to work after upgrade (rhevm-upgrade d...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Alex Lourie
David Botzer
infra integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-04 09:03 EST by David Botzer
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: si24.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade log (209.68 KB, application/octet-stream)
2012-11-04 09:03 EST, David Botzer
no flags Details
process-of-upgrade (3.61 KB, text/plain)
2012-11-04 09:05 EST, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-11-04 09:03:15 EST
Created attachment 638012 [details]
upgrade log

Description of problem:
Upgrade - DWH & Reports fail to work after upgrade (rhevm-upgrade doesnt detect them after upgrade)

As a result - Reports & DWH setup fails

Version-Release number of selected component (if applicable):
3.0 / ic158.1
3.1 / si23

How reproducible:
Always

Steps to Reproduce:
1.install rhevm3.0/ic158.1 + reports+dwh
2.upgrade to rhevm3.1/si23
  needs to reomve ipa-server
ipa-server-install --uninstall
yum remove ipa-*
  
Actual results:
rhevm-upgrade doesnt detect DWH & Reports installation after upgrade

Expected results:
Should display correct message to upgrade dwh & reports & execute setup

Additional info:
rhevm-upgrade didnt renamed the rhevm_history DB to ovirt-engine-history
Comment 1 David Botzer 2012-11-04 09:05:12 EST
Created attachment 638013 [details]
process-of-upgrade
Comment 2 Alex Lourie 2012-11-05 08:34:23 EST
The issue is in engine, as it incorrectly checks for installed reports 3.0
Comment 5 David Botzer 2012-11-12 06:03:42 EST
Fixed, upgrade 3.0/ic158.2 -> 3.1/si24.1
Upgrade passes correctly
-- (Manully need to remove ipa-server & rpmS
-- update repo
Fixed, upgrade 3.0/ic158.2 -> 3.1/si24.1

Notes:
Reports has Two issues after upgrade->

1. rhevm-dwh-setup runs correctly, but doesnt create DB - ovirt-engine-dwhd (as   
   rhevm_history already exists)

2. rhevm-reports-setup finishes correctly and gives message to run dwh as it 
   was not executed,
*DWH has not been setup, please execute: "ovirt-engine-dwh-setup" before accessing the reports URL*

Note You need to log in before you can comment on or make changes to this bug.