Bug 873483 - RFE: [WebTrans] should report to user when server is down or connection is lost
RFE: [WebTrans] should report to user when server is down or connection is lost
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
: 872041 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 19:25 EST by Patrick Huang
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121127-0017)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Huang 2012-11-05 19:25:04 EST
Description of problem:
When user enter WebTrans, if server is down or connection is lost, client is still not notified by this. When then perform an action needs to call the server, they will get back an specific error but not knowing the root cause. In some occasion error may only get logged into console and hidden from user.

Version-Release number of selected component (if applicable):
2.0-

How reproducible:
Always

Steps to Reproduce:
1.Go to WebTrans translation editor
2.Shutdown server
3.Perform an action like selecting a translation unit, search in project or save a translation
  
Actual results:
An specific error will show, i.e. search failed, TM or glossary result not coming back but logs an error in browser console.

Expected results:
Client should be notified that the connection to server has lost and they should refresh their browser to make sure the connection is still live.

Additional info:
Comment 1 Patrick Huang 2012-11-05 21:34:38 EST
committed into master:
https://github.com/zanata/zanata/commit/a71292921aca760f228e9131e45feeb0560bb629
Comment 2 Ding-Yi Chen 2012-11-08 00:37:47 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121108-1439)
Comment 3 Sean Flanigan 2012-11-08 20:53:17 EST
Please test on 2.0-SNAPSHOT as well.
Comment 4 Patrick Huang 2012-11-15 02:22:29 EST
*** Bug 872041 has been marked as a duplicate of this bug. ***
Comment 5 Alex Eng 2012-11-26 23:43:41 EST
Message "No response from server. Please refresh your page and make sure server is still up." is shown when connection lost.

Verified in Zanata version 2.0.3-SNAPSHOT (20121127-0017).

Note You need to log in before you can comment on or make changes to this bug.